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Introduction

Welcome to AnySite. System Administrators installing AnySite need to read this 
entire document for a successful installation. 

AnySite helps you to analyze the relationship between store performance and 
market trade area demographic characteristics. AnySite lets you integrate the 
specific data you need from various sources, so that you can connect, retrieve, 
report on, and map any information from your proprietary database to analyze 
trade area data.

Access to data is controlled using account permissions set through the AnySite 
Configurator tool, which is installed with AnySite. This allows an AnySite 
Administrator to restrict access to sensitive data.

For information on setting system preferences and defaults through AnySite’s 
Configurator tool, refer to the AnySite Reference after installing AnySite.

In this chapter:

Product Inventory. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .6
About this Guide  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .6
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Product Inventory
Your copy of AnySite installs the following to your system:

• AnySite – Server and client software.
• Data Manager tool – For importing and exporting data from the AnySite Data Engine.
• Configurator tool – For managing AnySite system settings.
• Data – Data purchased with AnySite for market and site analysis.
• Tutorial data – Sample data provided to follow along with the AnySite tutorial.
• Install Guide – This document, which provides installation and system configuration instructions.
• Reference Guide – Provides a reference for working with AnySite, and the Data Manager and 

Configurator tools.

About this Guide
This guide is organized as follows:

• Chapter 2: Before You Begin – Requirements and system setup needed.
• Chapter 3: Installing – Instructions for installing the AnySite Application.
• Chapter 4: Starting AnySite – Instructions on how to log in to and launch AnySite.
• Chapter 5: Upgrading Your Current Installation – Instructions on how to upgrade your 

existing AnySite installation to this new release.
• Chapter 6: Uninstalling – Instructions on how to remove AnySite from your system.

Conventions
This guide may provide full paths to menu commands. For example, File > Print is the same as “on 
the File menu, click Print”.

When referring to Configurator preferences the convention of Preferences > Layers > Linked is the 
same as “in the Preferences pane, click Layers, and then click Linked”.
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Before You Begin

When installing AnySite, it is important to decide your installation location, and 
deployment environment.

Note If you install AnySite incorrectly, you may need to remove the 
application from your computer and re-install it to fix any problems.

In this chapter:

Permissions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .10
System Requirements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .10
Default Install Path . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .10
Time/Space Considerations  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .10
Installation Scenarios  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .11
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Permissions
Administrative rights to the program files directory are required for installation. 

Once installed, users need read/write/modify rights to the AnySite.ini and AnySite.mdb files, which 
are located within the AnySite application directory. Give users read/write/modify rights to the entire 
AnySite application directory.

System Requirements

Default Install Path
The default install path is C:\Program Files\MapInfo\AnySite_XX, where XX is a two-digit country 
code, such as XX.

Time/Space Considerations
The AnySite install wizard installs both the AnySite application and data (streets, demographics, and 
geocoder for example). The length of time for the install will range from 1-4 hours depending on the 
speed of your media drive and file transfer across a network. The installation of AnySite cannot be 
stopped and restarted at a later date. Schedule enough time prior to beginning the install process.

Operating System: • Windows 7
• Windows XP Service Pack 2 or higher
• Windows 2000 with Service Pack 4 or higher
• Windows Server 2003 (Standard or Enterprise) Service Pack 1

Hardware: • Pentium IV Processor 1.x GHz or better, with 512MB of RAM (1GB 
or better recommended)

• 15-inch monitor, with graphic accelerator card, 16 bit color or 
greater. Minimum of 800x600 resolution is required.

Hard Disk Space: Dependent on the data purchased. 7GB with State data to 14+ GB with 
National data.

Software: Microsoft Word 2002, 2003, or later (recommended for viewing reports)
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The following chart provides an estimation of size needed when installing AnySite and its 
corresponding data. The footprint will change depending upon the geography purchased.

You have the option to install the data to a location separate from the AnySite application. The most 
common scenario is to install the application and data to the same machine. 

Installation Scenarios
During the install you have the option to perform a Single or a Shared setup type. A Single setup 
type is for a local installation, where a single user installs AnySite and the AnySite Client to a local 
machine. A Shared setup type is for a network installation where multiple users on a network will 
access AnySite.

For questions regarding installation scenarios please contact AnySite technical support via email at 
anysite.support@mapinfo.com or 1.800.552.2511 (option 1).

Local Installation (Single User)

A local installation installs and runs AnySite on a single machine. Choose a local installation if only a 
single user is going to access AnySite. 

For optimal performance of AnySite on a local machine, install the entire application: both server and 
client software.

Network Installation (Shared by Multiple Users)

A network installation installs AnySite (executable and all associated files) onto a network of 
machines. Choose a network installation if multiple users are going to access AnySite. Install 
AnySite from the console of the server where AnySite will reside, and install the AnySite Client onto 
each user’s local machine where they will run AnySite from. 

If you are installing to the network from a local machine, you must have a mapped drive to your 
network location. The mapped drive is only required for the installation process. UNC (Universal 
Naming Convention) paths may be used to run the application from a network. Refer to Final 
System Configuration in Chapter 3 on page 37.

Name Approximate Disk Space Needed

AnySite Program 500 MB

Single State Data 7 GB

Region (6 states) Data 11 GB

National Data 14 GB
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Installing

To successfully install AnySite, read this entire chapter before beginning. Refer 
to Before You Begin in Chapter 2 on page 9 for pre-installation requirements 
and planning.

During the installation procedure, you must make some decisions about your 
installation. Please read these instructions before installing, so that your 
installation runs smoothly.

Follow the directions for the Final System Configuration on page 37 after 
completing the main installation. These steps are required for every installation 
and will ensure that your AnySite installation is successful.

In this chapter:

Evaluation Version Users  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .14
Installing to a Local Machine (Single User) . . . . . . . . . . . . . . . . . .14
Installing to a Network (Shared by Multiple Users). . . . . . . . . . . .21
Installing AnySite on Windows 7  . . . . . . . . . . . . . . . . . . . . . . . . . .30
Installing the .NET Framework . . . . . . . . . . . . . . . . . . . . . . . . . . . .31
Installing your Data License File. . . . . . . . . . . . . . . . . . . . . . . . . . .34
Installing the AnySite Client  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .34
Final System Configuration. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .37
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Evaluation Version Users
If you currently have an evaluation version of AnySite installed on your machine, you must uninstall 
the evaluation version prior to installing the full version.

Installing to a Local Machine (Single User)
To Install AnySite onto a local machine:

1. Place the AnySite Installation DVD in the media drive.

Note If you are a Windows 7 user, see Installing AnySite on Windows 7 on page 30 for 
installation instructions that are specific to that operating system.

If the installation does not automatically start, click Run from the Microsoft Start menu, and click 
the Browse button. Go to the media drive and select Launch.exe. 
Select Install, and then select Install AnySite.

2. The Welcome screen appears. 
Click Next to continue.
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3. The License Agreement screen appears. 
Carefully read the License Agreement. Select I accept the terms in the license agreement to 
accept the terms of the agreement.
Click Next to continue the installation process.

4. The Customer Information screen appears. 
Enter your name, organization name, and serial number (all three fields are required).
The Serial Number is located on the outside of the AnySite box. This number is required for the 
installation to continue. If you are unable to locate your serial number, contact your sales 
representative for assistance (for contact information, see Installation Scenarios in Chapter 2 
on page 11).
Click Next to continue.
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5. The Data Unlocking screen appears. 
Enter your Unlocking Code. The unlocking code is included in the Unlock Code and Serial 
Number document included in the software box. The serial number and unlock code are 
connected to each other, if you receive a message stating your unlock code is invalid, recheck 
your serial number to see if it was keyed in properly.
Click Next to continue.

6. The Setup Type screen appears.
Select Complete or Custom, and then Click Next to continue.
• Complete installs AnySite and all of its components.
• Custom lets you select which program features and data to install, and lets you install them 

to different locations either on your hard drive or on a network drive.
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If you chose Complete, refer to Complete Installation for further instructions. If you chose Custom, 
refer to Custom Installation on page 19 for further instructions.

Complete Installation
To continue with a Complete installation:

1. The Destination Folder screen appears after clicking Complete in the Setup screen.
Choose This installation is for a single user to install AnySite and the AnySite Client to a local 
machine.
If you would like to change the default installation location, click Change to browse to a different 
location.
Click Next to continue.
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2. The Ready to Install the Program screen appears.
If you chose to deselect desktop icons, then you can launch these features from the Microsoft 
Start menu by clicking Programs > MapInfo > AnySite.
Click Install to begin the Installation process.

Note If the .NET Framework License Agreement screen appears, then you do not have a 
compatible version of Microsoft .NET Framework installed. To complete your installation, 
proceed to Installing the .NET Framework on page 31. 

3. The Installation Complete screen appears.
Click Finish to close the AnySite Installation wizard.

4. Complete the installation by rebooting the system. 

After rebooting, continue to Installing your Data License File on page 34.
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Custom Installation
This section continues from step 6  in Installing to a Local Machine (Single User) after choosing 
Custom in the Setup screen. The options for a Custom Setup include application files and data. 

You will have the option to select to install AnySite features, such as data, to your local hard drive or 
to a network drive. If installing to a network drive, then map the drive first. You may also choose not 
to install a feature.

Note Installing features to a network drive is not the same as installing AnySite on a network to be 
shared by multiple users. 

For optimal performance on a local machine, install everything to the local machine.

To continue with a Custom installation:

1. The Destination Folder screen appears after clicking Custom in the Setup screen.
Choose This installation is for a single user to install AnySite and the AnySite Client to the 
local machine.
If you would like to change the default installation location, click Change to browse to a different 
location.
Click Next to continue.

2. The Custom Setup screen appears.
By default, the wizard installs all features. To deselect a feature, click the feature icon and select 
This feature will not be available. Only selected features install.
Features install to your local hard drive in the folder indicated. To specify a different folder, click 
Change.
Click Next to continue.
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3. The Ready to Install the Program screen appears.
If you chose to deselect desktop icons, then you can launch these features from the Microsoft 
Start menu by clicking Programs > MapInfo > AnySite.
Click Install to begin the Installation process.

Note If the .NET Framework License Agreement screen appears, then you do not have a 
compatible version of Microsoft .NET Framework installed. To complete your installation, 
proceed to Installing the .NET Framework on page 31. 

4. The Installation Complete screen appears.
Click Finish to close the AnySite Installation wizard.
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5. Complete the installation by rebooting the system. 

After rebooting, continue to Installing your Data License File on page 34.

Installing to a Network (Shared by Multiple Users)
In a shared setup, you install AnySite to a single machine in a network of connected machines. You 
then install the AnySite Client on to those machines in the network that access AnySite. 

This section describes how to install AnySite. After completing the instructions in this section, you 
will install the AnySite Client on to all machines that will access AnySite. 

Note There is an option to install the AnySite Client as part of this main installation if the machine 
used to install to the network location will also be used to run AnySite.

You must have a mapped drive to your network location and full write permission to the drive to 
install the AnySite Client. The mapped drive is only required for the installation process.

To Install AnySite on a network:

1. Place the AnySite Installation DVD in the media drive.

Note If you are a Windows 7 user, see Installing AnySite on Windows 7 on page 30 for 
installation instructions that are specific to that operating system.

If the installation does not automatically start, click Run from the Microsoft Start menu, and click 
the Browse button. Go to the media drive and select Launch.exe. 
Select Install, and then select Install AnySite.
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2. The Welcome screen appears. 
Click Next to continue.

3. The License Agreement screen appears. 
Carefully read the License Agreement. Select I accept the terms in the license agreement to 
accept the terms of the agreement.
Click Next to continue the installation process.
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4. The Customer Information screen appears. 
Enter your name, organization name, and serial number (all three fields are required).
The Serial Number is located on the outside of the AnySite box. This number is required for the 
installation to continue. If you are unable to locate your serial number, contact your sales 
representative for assistance (for contact information, see Installation Scenarios in Chapter 2 
on page 11).
Click Next to continue.

5. The Data Unlocking screen appears. 
Enter your Unlocking Code. The unlocking code is included in the Unlock Code and Serial 
Number document included in the software box. The serial number and unlock code are 
connected to each other, if you receive a message stating your unlock code is invalid, recheck 
your serial number to see if it was keyed in properly.
Click Next to continue.



Installing to a Network (Shared by Multiple Users)

24 AnySite 8.8

6. The Setup Type screen appears.
Select Complete or Custom, and then click Next to continue.
• Complete installs AnySite and all of its components.
• Custom lets you select which program features and data to install, and lets you install them to 

different locations either on your hard drive or on a network drive.

If you chose Complete, refer to Complete Network Installation on page 25 for further instructions. 
If you chose Customer, refer to Custom Network Installation on page 27 for further instructions.
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Complete Network Installation
This section continues from step 6  in Installing to a Network (Shared by Multiple Users) on 
page 21, after choosing Complete in the Setup screen.

To continue with a complete installation:

1. The Destination Folder screen appears.
Choose This installation will be shared by others on a network and do one of the following:
• Accept the default destination folder by clicking Next to install on this local machine.
• Change the destination folder by clicking Change to install to a machine on the network by 

selecting a mapped drive (you will require full write permission to the location). The Change 
Current Destination Folder screen appears to select a location on the network.

2. The Choose Installation Options screen appears.
Deselect the AnySite Client option if you do not want to install it on this machine.
Deselect the desktop icon options if you do not want to install them. You can launch these 
features from the Microsoft Start menu by clicking Programs > MapInfo > AnySite.
Click Next to continue.
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Note If installing to Windows Server 2003, then install the AnySite Client separately as 
described in Installing the AnySite Client on page 34.

3. The Ready to Install the Program screen appears.
Click Install to begin the Installation process.

Note If the .NET Framework License Agreement screen appears, then you do not have a 
compatible version of Microsoft .NET Framework installed. To complete your installation, 
proceed to Installing the .NET Framework on page 31. 

4. The Installation Complete screen appears.
Click Finish to close the AnySite Installation wizard.
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5. Complete the installation by rebooting the system. 

You must reboot the system and then continue to Installing your Data License File on page 34.

Custom Network Installation
This section continues from step 6  in Installing to a Network (Shared by Multiple Users) on 
page 21, after choosing Custom in the Setup screen. The options for a Custom Setup include 
application files and data packages. 

When you select a feature in step 3  of the following procedure, a menu appears allowing you to 
choose to install the feature and its sub-features to your local hard drive or a network drive. If 
installing to a network drive, then map the drive for the installation.

Note Installing components to a network drive is not the same as installing AnySite on a network 
to be shared by multiple users.

To continue with a Custom installation:

1. The Destination Folder screen appears.
Choose This installation will be shared by others on a network and do one of the following:
• Accept the default destination folder by clicking Next to install on this local machine.
• Change the destination folder by clicking Change to install to a machine on the network by 

selecting a mapped drive (you will require full write permission to the location). The Change 
Current Destination Folder screen appears to select a location on the network.
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2. The Choose Installation Options screen appears.
Deselect the AnySite Client option if you do not want to install it on this machine.
Deselect the desktop icon options if you do not want to install them. You can launch these 
features from the Microsoft Start menu by clicking Programs > MapInfo > AnySite.
Click Next to continue.

Note If installing to Windows Server 2003, then install the AnySite Client separately as 
described in Installing the AnySite Client on page 34.

3. The Custom Setup screen appears.
By default, the wizard installs all features. To deselect a feature, click the feature icon and select 
This feature will not be available. Only selected features install.
Features install on your local hard drive in the folder indicated. To specify a different folder, click 
Change.
Click Next after the custom features have been selected.
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4. The Ready to Install the Program screen appears.
Click Install to begin the Installation process.

Note If the .NET Framework License Agreement screen appears, then you do not have a 
compatible version of Microsoft .NET Framework installed. To complete your installation, 
proceed to Installing the .NET Framework on page 31. 

5. The Installation Complete screen appears.
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Click Finish to close the AnySite Installation wizard.

6. Complete the installation by rebooting the system. 

You must reboot the system and then continue to Installing your Data License File on page 34.

Installing AnySite on Windows 7
Installing AnySite on Windows 7 requires you to initiate the installer in a different way than is 
required for other supported Windows operating systems. 

To install AnySite US on Windows 7:

1. Verify that you have administrative rights to the machine.
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2. Place the AnySite Installation DVD in the DVD drive. If the DVD autoruns, the following screen 
appears:

3. Do not click Install on this screen. Instead, click Exit.
4. In your file system, locate the setup.exe file at the root of the DVD directory.
5. Right-click on the setup.exe file.
6. Select Run as Administrator.
7. Continue with the remaining installation steps (step 2 on page 14 for installing to a local 

machine, or step 2 on page 22 for installing to a network).
Once the install is complete, you can run the application with typical user rights. 

Installing the .NET Framework
This part of the installation occurs when you do not already have a compatible version of Microsoft 
.NET framework installed on your machine. Microsoft .NET Framework version 2.0 is required to run 
AnySite. (For information about the Microsoft.NET framework, see www.microsoft.com/net.)

www.microsoft.com/net
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1. The Welcome to Microsoft .NET Framework 2.0 Setup dialog appears.
Click Next to continue.

2. The License Agreement screen appears. 
Carefully read the License Agreement. Select "I accept" to agree to the terms.
Click Install to continue the installation process.
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The Installing .net screen appears with a progress bar indicating the status of the installation 
process.

3. The Installation Complete screen appears.
Click Finish to complete the .NET installation.

You must reboot the system and then continue to Installing your Data License File on page 34.
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Installing your Data License File
A unique license ships with your copy of AnySite to give you access to the data you purchased. This 
license is on a license CD that is included with your AnySite media.

To Install the data license file:

1. Place the License CD in the media drive.
If the installation does not automatically start, click Run from the Microsoft Start menu, and click 
the Browse button. Go to the media drive and select INSTALL.EXE.

2. In the License Installer screen click Install to copy the license file to the AnySite installation 
location (C:\Program Files\MapInfo\AnySite_XX\Data\ASDE for example).

3. A Notice dialog appears.
Click OK when prompted that the installation is complete.

If you selected a single user setup installation, continue to Final System Configuration on 
page 37.

If you select a multiple user setup installation or you installed to the Windows 2003 operating 
system, continue to Installing the AnySite Client instructions.

Installing the AnySite Client
The AnySite Client allows a user to access the AnySite application.

Single User Installations:

If you selected a Single setup type installation on Windows XP, then you do not have to install the 
AnySite Client. The Client installs by default for you. Skip to Final System Configuration on 
page 37.

If you installed on Windows 2003 server then you must install the Client. Follow the instructions in 
the next section Launching the AnySite Client Setup Wizard on page 35.
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Multiple User Installations:

If you selected a Shared (network) setup type, so that multiple users can access AnySite, then install 
the AnySite Client on each machine that will access AnySite.

The AnySite Client Installer is a ClientSetup.exe file located under the AnySite installation folder 
(C:\Program Files\MapInfo\AnySite_XX by default). Map the drive to the AnySite installation folder 
where the user will be running AnySite from, and then run the ClientSetup.exe file from the client 
machine (as described in the next section Launching the AnySite Client Setup Wizard). 

Map a drive on each client machine using the same map drive letter. After running the Client 
installation on each client machine, run the final system setup as described under Final System 
Configuration on page 37.

The mapped drive is only required for the installation process. Use UNC to run the application from a 
network. 

Note The Client setup creates shortcuts pointing to the mapped drive not the UNC.

Launching the AnySite Client Setup Wizard
To launch the Client Setup wizard to install AnySite Client:

1. Locate the ClientSetup.exe file in the folder where AnySite is installed. By default, AnySite 
installs to C:\Program Files\MapInfo\AnySite_XX. Double-click on the ClientSetup.exe file to 
launch the Client Setup wizard.

If the Welcome to Microsoft .NET Framework 2.0 Setup screen appears, follow the instructions 
under Installing the .NET Framework on page 31 and then continue with the next step.
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2. The Welcome screen appears. 
Click Next to continue.

3. The Ready to Install the Program screen appears.
Select which desktop Shortcuts to create. (The AnySite Configurator requires AnySite 
administrative permissions to access.)
Click Install to begin the Installation process. 

4. The Install Shield Wizard Completed screen appears once the AnySite Client has been installed. 
Click Finish to complete the Installation.
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The help systems for AnySite and for the Data Manager do not display on AnySite Client machines 
due to a Microsoft network security setting. You must copy the help files to the client machines, so 
that users can open them. Copy the files called MapInfoAnySite.chm and AnySiteDataManager.chm 
files from the AnySite Documentation folder (C:\Program Files\MapInfo\AnySite_XX\Documentation) 
to the corresponding folder on each client machine.

Proceed to Final System Configuration.

Final System Configuration 
Before launching AnySite for the first time, you must complete the steps in the following sections:

• Launching the Configurator
• Importing Repository Transfer (ART) Files for your Data
• Cataloging System Data if Stored to a Non-Default Location

These settings are made in the Configurator, which is a utility for managing your AnySite installation.

If you installed AnySite to a network location, so that the AnySite Client is on a different machine, 
then perform all of these steps on each client machine.

Launching the Configurator
To launch the AnySite Configurator and complete the setup of your installation:

1. Either click the AnySite Configurator icon on your desktop or click Programs > MapInfo > 
AnySite XX > AnySite Configurator in the Microsoft Start menu.

2. The Login dialog opens. 
Enter the default user name and password when prompted: type Administrator for the username 
and leave the password blank. Click OK to proceed. Usernames are case sensitive, so make 
sure Administrator has a capital "A".
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The Cataloger, a utility accessible from the Configurator, will scan several settings for AnySite; 
you may receive a message that the Cataloger will adjust these settings. If at a later time you 
receive this message, then rerun the Cataloger as described under Cataloging System Data if 
Stored to a Non-Default Location on page 41

3. The AnySite Configurator opens. 

Proceed to Importing Repository Transfer (ART) Files for your Data.

Importing Repository Transfer (ART) Files for your Data
After installing your license file, you must import repository transfer (ART) files, which contain 
reports, thematics, and other settings. Reports are data dependent. If you run a report and you have 
not purchased the accompanying data for the report, then a "data not licensed" message appears.

Determine Which ART Files to Import

Use the following table to determine which ART files to import relative to the data you purchased and 
are licensed for. You must import the corresponding ART files using the Configurator.
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MapInfo Canada

Bundle ART File

Standard MapInfo Canada 20XX Standard Bundle.art

Business Summary MapInfo Canada 20XX Business Reports.art

CANEX MapInfo Canada 20XX CANEX Reports.art

CANEX-Food MapInfo Canada 20XX CANEX Food Reports.art

PSYTE MapInfo Canada 20XX PSYTE Advantage Reports.art

PMB-Print Media Bureau (like MRI) MapInfo Canada 20XX PMB Reports.art

HFE-HH Facilities and Equipment MapInfo Canada 20XX Household Facilities and Equipment 
Reports.art

DDI-Disposable and Discretionary 
Income

MapInfo Canada 20XX Disposable and Discretionary 
Income Reports.art

MapInfo U.S.

Bundle ART File

Basic MapInfo US 20XX Basic Bundle.art

Market MapInfo US 20XX Market Bundle.art

PSYTE MapInfo US 20XX PSYTE Bundle.art

PSYTE Financial MapInfo US 20XX PSYTE Financial Reports.art

CPD-Consumer Potential Detail MapInfo US 20XX CPD Bundle.art

Business Summary (SIC and NAIC) MapInfo US 20XX Business Summary Bundle.art

Demand Insight MapInfo US 20XX Demand Insight.art

Puerto Rico MapInfo PR 20XX Reports.art

Puerto Rico MapInfo PR 20XX Thematics.art

Cultural Background MapInfo US 20XX Cultural Background Reports.art

Wealth and Financial Assets MapInfo US 20XX Wealth and Financial Assets Bundle.art
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AGS

Bundle ART File

Standard AGS 20XX Standard Bundle.art

Mosaic AGS 20XX Mosaic Reports.art

Crime AGS 20XX Crime Risk Reports.art

CEX-Consumer Expenditure AGS 20XX CEX Reports.art

Business Basic AGS 20XX Business Basic Reports.art

Business Complete AGS 20XX Business Complete Reports.art

Claritas

Bundle ART File

PopFacts Claritas 20XX PopFacts Bundle.art

PopFacts with CBP Claritas 20XX CBP PopFacts Reports.art

Retail Analyst Claritas 20XX Retail Analyst Bundle.art

CBP-Consumer Buying Power Claritas 20XX CBP Reports.art

WPBE-Workplace Business & 
Employment

Claritas 20XX WPBE Reports.art

PRIZM-NE Claritas 20XX PRIZM NE Reports.art

Business Facts Occupation Claritas 20XX Business Facts Occupation Reports.art

TDSIC-Two Digit SIC Bus Summary Claritas 20XX TDSIC Reports.art

PRIZM-NE Daytime Claritas 20XX PRIZM NE Workplace Reports.art

Income Producing Assets Claritas 20XX Income Producing Assets Reports.art

PopStats

Bundle ART File

Standard PopStats 20XX Qx Bundle.art  (x=1-4)
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Import ART Files Using the Configurator

To import the ART files for your data in the Configurator:

1. Click Tools > Importing Preferences in the AnySite Configurator menu.
2. In the Import Preferences dialog, select the *.art file to import (according to the data bundle that 

you purchased, as identified in the preceding table) and then click Open.
You may need to select the Look in list to locate the *.art files the ART Files folder. The default 
location is C:\Program Files\MapInfo\AnySite_XX\Art Files.

3. In the Select Preferences to Import dialog, select all of the preferences in the list, by pressing the 
Ctrl key, and then click OK.

4. Repeat these steps for each ART file to import (if you have licensed data outside the base 
demographic offering).

You have completed the system configuration and are now ready to launch AnySite, proceed to 
Chapter 4: Starting AnySite.

If you installed the data supplied with AnySite to a non-default location, then proceed to Cataloging 
System Data if Stored to a Non-Default Location before launching AnySite.

Cataloging System Data if Stored to a Non-Default Location
If the data supplied with AnySite was installed to a non-default location, then configure AnySite to 
the location of the data files using the AnySite Configurator as described in this section.

Shared (network) installations must install the AnySite Client before continuing. If you have not 
already done so, see Installing the AnySite Client on page 34.

To catalog the data stored in a non-default location, in the Configurator:

1. Click Tools > Cataloger in the AnySite Configurator menu.
2. In the Disk Drives to Catalog dialog, check all the drives that contain AnySite and any additional 

data for use with AnySite. 

If you installed StreetPro®, then select its data directories for cataloging. The default StreetPro 
location is C:\Program Files\MapInfo\Professional X.X\SPXXXX.
If you installed AnySite to a network location, so that the AnySite Client is on a different machine, 
then select the AnySite installation directory (which will be a mapped drive). If you could not use 
the same drive letter when mapping drives on the client machines, then you must also select the 
Use UNC Paths check box. 
Ensure that the Update Layer Paths check box is selected to fix any invalid paths, and then click 
OK.
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Note The Update Layer Paths check box updates paths to tables that may be invalid. The Use 
UNC Paths check box records the Universal Naming Convention (UNC) location to the 
data. UNC codes are used in network deployments where consistent network drive 
mappings for each user are not guaranteed. The Cataloger still requires the drives be 
mapped on the machine running the cataloger.

Note You must use the same drive letter for all client installations.

3. In the Drive Directories dialog, check all the drives that contain AnySite data, and then click OK.

You have completed the system configuration and are now ready to launch AnySite, proceed to 
Chapter 4: Starting AnySite. 

Note You must reboot the system before running AnySite for the first time.

Run the Cataloger after purchasing additional data sources or when moving data sources, so that 
AnySite recognizes the data.
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Starting AnySite

This chapter describes how to launch AnySite.

In this chapter:

Logging into and Launching AnySite. . . . . . . . . . . . . . . . . . . . . . .46
Handling Data Not Found Messages  . . . . . . . . . . . . . . . . . . . . . . .46
Default Locations for Data. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .47
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Logging into and Launching AnySite
If you have not yet run the final system configurations using the Configurator, then you must do so 
first, see Final System Configuration in Chapter 3 on page 37.

Note You must reboot the system before running AnySite for the first time.

To start AnySite:

1. Either click the AnySite icon on your desktop or click Programs > MapInfo > AnySite XX in the 
Microsoft Start menu.

2. The Login dialog opens.
Enter the default user name and password when prompted: type Administrator for the username 
and leave the password blank. Click OK to proceed. Usernames are case sensitive, so make 
sure Administrator has a capital "A".

Note If you receive a data not found message, then proceed to Handling Data Not Found 
Messages.

AnySite opens. Refer to the Tutorial section in the AnySite Reference for an overview of how to work 
with AnySite.

Handling Data Not Found Messages
The first time you launch AnySite, you may be prompted to locate data files if they are installed to a 
non-default location.

Drive Time Data Not Found

When launching AnySite the first time, you may get a Drive Time Data Not Found message 
regarding the location of the Drive Time Data. Use the Browse button in the message dialog to 
navigate to the proper directory (C:\Program Files\MapInfo\AnySite_XX\Data\AGS\Freeway for 
example) and then click OK to close the dialog.
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MapMarker® Data Not Found

When launching AnySite the first time, you may get several MapMarker Data Not Found messages 
regarding the location of the MapMarker address data. This means that AnySite does not have the 
correct path to your geocoder data. Use the Browse button in the dialog to navigate to the proper 
directories, and then click OK.

Default Locations for Data
The following are default locations for data products:

• OEM Marker component of AnySite: 
C:\Program Files\MapInfo\AnySite_XX\Data\MapMarker\Data

• Full version of MapMarker Plus, requires a separate install and runs outside of AnySite: 
C:\Program Files\MapInfo\MapMarker\Data

• Full version of MapMarker Plus for Canada, requires a separate install and runs outside of 
AnySite Canada: C:\Program Files\MapInfo\MapMarker Plus Canada\Canada
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Upgrading Your Current 
Installation

Depending on your data provider, your demographic content may be updated 
one to four times a year. Updated templates for all Standard reports, Thematics, 
Hotspots, and Capture Methods are provided with each demographic update.

In this chapter:

Backing-Up Custom Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .50
Are you upgrading from AnySite 8.7.x?. . . . . . . . . . . . . . . . . . . . .50
Upgrading AnySite . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .51
Updating Reports and Thematics . . . . . . . . . . . . . . . . . . . . . . . . . .52
Upgrading the AnySite Client . . . . . . . . . . . . . . . . . . . . . . . . . . . . .55
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Backing-Up Custom Files
Before upgrading your current installation of AnySite, it is recommended you move or copy the 
following file types to a new location, outside of the AnySite application directory: 

• anysite.mdb (located in the AnySite application directory) 
• custom layers (for example, Tables/Server/Linked)
• .SIT files (Saved Sites) (AnySite\Sites)
• .LST (Batch List)
• .ACT (Batch Actions) (AnySite\Actions)
• .XML (Index Files) (AnySite\Indexing)
• custom symbols (AnySite\MapX\CUSTSYMB)

Create an ART (AnySite Repository Transfer *.art) file of any custom reports, Thematics, Hotspots, 
capture methods, and any other custom files that you wish to retain, such as:

• custom map preferences
• custom reports
• custom report templates
• custom thematics
• custom Hotspots
• custom Capture Methods

To do this, run the Configurator and click Tools > Export Preferences. Select the custom reports, 
thematics, capture methods, and map preferences that you have created. Save the ART (AnySite 
Repository Transfer *.art) file to a safe location that is outside of the AnySite application directory for 
future access.

Are you upgrading from AnySite 8.7.x?
If you are upgrading from AnySite 8.7.x, then you must first delete the MapMarker folder where 
AnySite is installed. This is necessary as a result of changes made to the structural organization of 
the MapMarker files.

In Windows Explorer, navigate to the MapMarker folder. In a standard install this will be C:\Program 
Files\MapInfo\AnySite_XX\Data\MAPMARKER. Select the MAPMARKER folder and click File > 
Delete.

Continue with the instructions in the next section, Upgrading AnySite.
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Upgrading AnySite
To upgrade from the previous release:

1. Place the AnySite Installation DVD in the media drive.

Note If you are a Windows 7 user, see Installing AnySite on Windows 7 on page 30 for 
installation instructions that are specific to that operating system, then continue to step 2 
below.

If the installation does not automatically start, click Run from the Microsoft Start menu, and click 
the Browse button. Go to the media drive and select Launch.exe. 
Select Install, then select Install AnySite.

2. The InstallShield Installer Update Completed screen displays.
Click Continue.

3. A prompt to upgrade your AnySite application and data displays.
Click Yes.

4. The Welcome screen displays. 
Click Next to continue.
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Follow the installation directions that match your current deployment (local or network). When 
prompted, check the installation path to make sure you are upgrading the desired AnySite 
installation. 

After completing the install and final system configuration, continue with the directions under 
Updating Reports and Thematics on page 52 to update your custom reports and thematics.

Updating Reports and Thematics
If you are upgrading demographic data, then the existing standard reports (Summary, Detail, 
Comparative, and Quick View), thematics (Shades, Hotspots and Dot Densities), and Capture 
Methods in your AnySite now need to be updated. Changes made by your demographic data 
provider may prevent the existing data from functioning properly within AnySite. 

Updating Standard Reports and Thematics
To change the vintage on standard reports:

1. Launch the AnySite Configurator. Either click the AnySite Configurator icon on your desktop 
or click Programs > MapInfo > AnySite XX > AnySite Configurator from the Microsoft Start 
menu.
Enter the default user name and password when prompted: type Administrator for the username 
and leave the password blank. Usernames are case sensitive, so make sure Administrator has a 
capital "A".
Click OK to proceed. 

2. Click Tools > Import Preferences. 
3. Navigate to the ART Files folder under the AnySite installation folder (C:\Program 

Files\MapInfo\AnySite_XX\Art Files for example).
4. Select the most recent .ART file. 
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5. Highlight all items, and click OK. 
The Configurator is updated with the new reports and thematics that correspond with the data.

6. Repeat from step 3 for all the new/updated ART files.

Note A detailed electronic copy of exporting and importing preferences directions is provided on 
the AnySite Installation disk under Upgrade\Documentation.

Updating your Custom Reports and Thematics
It will only be necessary for you to manually update the "Verbose" descriptions on reports, thematics, 
Hotspots, and Capture Methods that you have customized. The underlying demographic content 
(numbers) are automatically updated by the AnySite installer, the "Verbose" descriptions (2004 Total 
Population) will have to be manually altered from 2004-2005 via the Configurator. 

All reports, thematics, Hotspots, and capture methods will continue to run successfully using the 
newest content from the installer. However, without importing the updated "Standard" reports and 
modifying the "verbose" descriptions on your custom reports, the printed maps and reports will 
continue to display the previous data vintage.

To change the vintage on custom reports:

1. Launch the AnySite Configurator. Either click the AnySite Configurator icon on your desktop 
or click Programs > MapInfo > AnySite XX > AnySite Configurator from the Microsoft 
Start menu.
Enter the default user name and password when prompted: type Administrator for the username 
and leave the password blank. Usernames are case sensitive, so make sure Administrator has a 
capital "A".
Click OK to proceed. 

2. On the Preferences menu, click Reports. 
3. Select your custom report, and click Edit.
4. Select a variable and modify the verbose descriptions. Click OK when you have finished.
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Some of your existing thematics and reports may continue to run, but the verbose vintage 
descriptions, such as 2004, will be incorrect, or you may see NOT LICENSED on your reports. 
These variables will need to be manually replaced with the newly updated data. To do this:

1. In the Configurator from the Tools menu, click Update Preferences. 
2. In the Update Preferences dialog, type the vintage description in to the Search For box.

3. Select the found items to update and move them to the Replace With list by clicking the right 
arrow button. 

4. In the Replace With box, type the new vintage description and then click OK.
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Upgrading the AnySite Client
To upgrade the AnySite Client software, run the ClientSetup.exe file located in the AnySite 
installation folder (C:\Program Files\MapInfo\AnySite_XX for example). 

Network clients need to be uninstalled from the client machine and reinstalled to guarantee a correct 
update to the system. Follow the directions under Installing to a Network (Shared by Multiple 
Users) in Chapter 3 on page 21.

AnySite integrates data from several third party data vendors. There may be times when changes to 
the data will affect AnySite functionality. In some cases, the best option will be to install a new 
version of the application, with the new data. We are continuously working with our vendors to 
establish consistent releases of the various data products to minimize these occurrences.
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Uninstalling

To uninstall your AnySite software, follow the instructions provided here.

In this chapter:

Uninstalling the AnySite Application . . . . . . . . . . . . . . . . . . . . . . .58
Uninstalling the AnySite Client . . . . . . . . . . . . . . . . . . . . . . . . . . . .58
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Uninstalling the AnySite Application
To uninstall the AnySite application, click Start > Settings > Control Panel > Add or Remove 
Programs and select AnySite. Click Remove for this application. A prompt displays asking if you 
would like to remove AnySite from your computer. Click Yes to proceed with the uninstall.

You are then prompted if you would like to remove all user files from the application directory. 
Selecting Yes removes the entire application directory and all contents of that directory. This 
includes any files you may have created in the AnySite directory, such as saved sites, custom 
location or boundary layers. By selecting No, only the Sites, and Art Files directories are left 
untouched.

Once the installer completes, AnySite is removed from your system.

Uninstalling the AnySite Client
To Uninstall the AnySite Client, click Start > Settings > Control Panel > Add or Remove 
Programs and select AnySite Client. Click Remove for this application. You are prompted if you 
would like to remove the AnySite Client from your computer. Click Yes to proceed with the uninstall.

Once the installer completes, the AnySite Client will be removed from your system.



Performance Tuning a 
Network Installation

If you selected a Shared setup type, so that multiple users can access AnySite, 
then consider tuning your installation to improve AnySite performance.

In this chapter:

Network Speed . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .60
Virus Scanner Software Settings  . . . . . . . . . . . . . . . . . . . . . . . . . .60
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Network Speed
Using a 100 Megabit network connection is optimal. Using a slower network connection affects the 
refresh rate when panning or refreshing the map view.

Virus Scanner Software Settings
AnySite performance slows when virus software scans AnySite data. The performance decrease is 
noticeable with a network installation when multiple people access AnySite.

AnySite opens many data layers for display in the map view. A data layer consists of five files that 
AnySite launches to display the layer. There may be 16 to 19 layers on display in the map view. 
AnySite queries all of the layer files when you pan or refresh a map.

To improve performance, set the virus software to exclude the AnySite data directory from the virus 
scan (the C:\Program Files\MapInfo\AnySite_XX\Data directory for example), or to exclude the 
following file type extensions from the virus scan:

• .tab – A MapInfo table file that describes the format of the data.
• .dat – A file containing tabular data.
• .map – A file that describes the graphic objects.
• .id – A cross reference file that links the data with the graphic objects.
• .ind – An index file for searching for map objects.
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