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AnySite Australia 2009 Data 
Update Notes

This document contains information for installing the 2009 E&P data updates for AnySite® 

Australia, version 8.8.1 build 191.

This release also provides the new Mesh Block geography level (see “About the Mesh Block 
Geography Level” on page 6 for more information). If you are an upgrade customer and wish 
to use this new geography level, see “Upgrading with Mesh Block Data” on page 6 for 
instructions.

If you require assistance with this update, please contact Technical Support Australia via phone 
at 1.800.648.899 (toll free) or email pbbi.support@pb.com. 
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Installing Data
Before you begin you must exit AnySite if it is open and back up any custom files 
you have in your current installation (for details, see “Upgrading Your Current 
Installation” chapter of the AnySite Version 8.8 Install Guide). This includes the 
Anysite.ini file, which is overwritten during an upgrade.

To install the AnySite data update onto a local machine:

1. Place the AnySite data update DVD in the media drive.
If the installation does not automatically start, click Run from the Microsoft 
Start menu, and click the Browse button. Go to the media drive and select 
Launch.exe. 
Select Install, and then select Install AnySite.

2. At the prompt, click Yes to accept the upgrade.
3. The Welcome screen appears. 

Click Next to continue.
4. Follow the installation directions that match your current deployment (local or 

network). When prompted, check the installation path to make sure you are 
upgrading the desired AnySite installation. 

http://www.pbinsight.com/support/product-documentation/details/anysite
http://www.mapinfo.com.au
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Manual Installation Instructions
If you prefer, or if you have an issue running the installer from the DVD, you can also install the data update by 
manually copying the new data files and the AnySite Repository Transfer (ART) file from the AnySite DVD to your 
AnySite installation location.

To copy data files:

1. Place the AnySite DVD in the DVD drive. The Welcome screen displays. 

2. Click Browse CD.

3. Click Browse Now.

4. Launch Windows Explorer.

5. In Windows Explorer, navigate to the ASDE folder on the AnySite DVD, located under ...Upgrade\Data\ASDE.

6. In the ASDE folder on the AnySite DVD, highlight all of the files by clicking Select all from the Edit menu. Copy all 
of the files by clicking Copy from the Edit menu.

7. In Windows Explorer, navigate to your AnySite installation. The default AnySite location is C:\Program 
Files\MapInfo\AnySite_AU\Data\ASDE. 

8. In the ASDE folder in your AnySite installation, paste the files by clicking Paste from the Edit menu.

Choose to overwrite the existing files when prompted.

To copy the ART files:

1. In Windows Explorer, navigate to the ART Files folder on the AnySite DVD. The ART File folder is located under 
Upgrade\ART Files.

2. In the ART Files folder, select the MapInfo Australia Census 2006 Bundle.art file and the other ART files that you 
purchased and are licensed for.

3. Copy the files by clicking Copy from the Edit menu.

4. In Windows Explorer, navigate to your AnySite installation. The default AnySite location is C:\Program 
Files\MapInfo\AnySite_AU\ART Files. 

5. In the ART Files folder in your AnySite installation, paste the files by clicking Paste from the Edit menu.

Choose to overwrite the existing files if prompted.

To copy the documentation files:

1. In Windows Explorer, navigate to the Documentation folder on the AnySite DVD. The Documentation folder is 
located under Upgrade\Documentation.

2. In the Documentation folder, select all the files and click Copy from the Edit menu.

3. In Windows Explorer, navigate to the Documentation folder in your AnySite installation. The default AnySite 
location is C:\Program Files\MapInfo\AnySite_AU\Documentation. 

4. In the Documentation folder in your AnySite installation, paste the files by clicking Paste from the Edit menu.

Choose to overwrite the existing files if prompted.

Installing the License
For this data update, you must also install the license file.

1. Place the License CD in the DVD drive.

If the installation does not automatically start, click Run from the Microsoft Start menu, browse to the DVD drive, 
and select INSTALL.EXE.
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2. In the License Installer screen click Install to copy the license file to your AnySite ASDE folder (ensure the path is 
correct for your installation C:\Program Files\MapInfo\AnySite_AU\Data\ASDE is the default location).

3. A notice dialog appears. Click OK when prompted that the installation is complete. 
4. Important: Locate the new cledata.cdl and cledata.cdl.icn geolicense files on the License CD, then manually copy 

them to your ASDE folder. This action is required due to a known issue with the license installer (see Geolicense 
Files Not Copied After Upgrade Install on page 5).

If the license installation is not working, point to the license file using AnySite Configurator:

1. Open the AnySite Configurator.
2. From the Tools menu, select ASDE Settings.
3. In the License Path text area, click the Browse button and point to the new license file (for example, C:\Program 

Files\MapInfo\AnySite_AU\Data\ASDE\[NAME].lic). 
4. Click OK.

Importing ART Files
After installing the license, import the ART files. To do this:

1. Launch the Configurator.

2. From the Tools Menu, select Import Preferences.

3. In the Import Preferences dialog:
a. From the Look in list, select the ART Files folder where AnySite is installed. The default location is C:\Program 

Files\MapInfo\AnySite_AU\ART Files.
b. From the list of files, select the MapInfo Australia Census 2006 Bundle.art file.
c. Click Open.

4. In the Select Preferences to Import dialog, select all of the reports in the list and click OK.

Choose to overwrite the existing files if prompted.

Note This will erase any changes you have made to the standard reports listed in this .ART file. If you need to 
preserve these changes you should backup these reports using a separate exported .ART file. Clicking OK 
will not erase any changes made to your own custom reports, however.

5. Repeat steps 2–4 for each of the additional ART files that you purchased and are licensed for.

Your data update is now complete. Restart AnySite to begin working with the data.
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What’s Changed in this Release

DriveTime

New Matrix.TAB Files

Two Drivetime files, Default (Matrix.TAB) and Restricted (Matrix_Urban_Restricted.TAB), are now installed in the 
DriveTime directory in two new subfolders, Default and Restricted, respectively:

For new installations as well as upgrades, the DriveTime section in the Anysite.ini file points to the Restricted folder 
where the Matrix_Urban_Restricted.TAB file is located:

[DriveTime]

...

DataPath=C:\Program Files\MapInfo\AnySite_AU\Data\Drivetime\Restricted\

If you have customized your Matrix.tab file and would like to continue to use this file, edit the AnySite.ini file and 
change the DataPath setting as shown below:

DataPath=C:\Program Files\MapInfo\AnySite_AU\Data\Drivetime\

Or, if you require the default Matrix.TAB with the original speeds, instead of the Matrix_Urban_Restricted.TAB, change 
the DataPath setting as show below:

DataPath=C:\Program Files\MapInfo\AnySite_AU\Data\Drivetime\default 

New Anysite.ini Setting

A new setting has been added to the Anysite.ini under DriveTime for TravelLimitDistance. 

;What is the maximum distance (in miles) that the engine should search to find 
this route? (smaller settings will improve performance, but may miss routes)

TravelLimitDistance=1000

POI Directory
In this release of AnySite Australia, the original POI directory at \MapInfo\AnySite_AU\Data\POI is replaced by an 
updated one at \MapInfo\AnySite_AU\Data\STREETS\POI.

If you are an existing user, remove the old POI directory and rerun Cataloger through Configurator to use the new one. 
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Known Issues

ART Files Not Removed by the Installer
Previous year's data and report files (.ART files) are not removed by the installer.

Cataloger Error
When you run the Cataloger after installing AnySite data to a non-default location, a Cataloger error may appear. Run 
the Cataloger a second time to ensure all variables and geography levels are registered properly.

Geolicense Files Not Copied After Upgrade Install 
After the data installation, the attributes of the geolicense files cledata.cdl and cledata.cdl.icn are set to Hidden. If you 
attempt to run the license CD after this installation, these files are not copied over due to the change in file properties. 
If you are an upgrade customer, you must manually copy the two files (cledata.cdl and cledata.cdl.icn) to the ASDE 
folder as per step 4 on page 3.

“Cannot open database [NAME] at Geolevel [XY]”
Not all data variables are available at the indicated geography level. For example, the error “Cannot open database 
STMILON at Geolevel MB” appears when running reports at the Mesh Block level against databases other than 
CAMEO or EuroDirect. This error also occurs with all Thematics.Certain kinds of data variables are not available at a 
certain geography levels. A table containing what is offered is available in the documentation folder (ABS Profiles and 
Geographies in AnySite Australia.xls).

Expenditure Reports Appear Twice
The 2009 “MapInfo Australia Expenditure Reports.art” file has two renamed Summary reports— “Average Expenditure 
Report” and “Total Expenditure Report.” The 2008 versions of these reports have plural spellings—“Average 
Expenditures Report” and “Total Expenditures Report.” Therefore, after performing an upgrade install then importing 
the 2009 “MapInfo Australia Expenditure Reports.art” file, you see both the singular and plural versions of each report 
in the Show Reports reports side panel. 

Since both reports display the same data, you can delete the older 2008 versions with the plural spellings in the 
Configurator.

Drive Time Data Not Found
After launching AnySite the first time after the data update, you may get a Drive Time Data Not Found message 
regarding the location of the Drive Time Data. Use the Browse button in the message dialog to navigate to the proper 
directory (C:\Program Files\MapInfo\AnySite_AU\Data\AGS\Freeway for example) and then click OK to close the 
dialog.
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MapMarker Data Not Found
When launching AnySite the first time, you may get several MapMarker Data Not Found messages regarding the 
location of the MapMarker address data. This means that AnySite does not have the correct path to your geocoder 
data. Use the Browse button in the dialog to navigate to the proper directories, and then click OK.

If you see a MapMarker Data Not Found message that returns error 1795, this means that the default maximum 
memory setting for the JVM has been reduced to 256MB instead of the required 512MB. Restore the default value to 
512MB by editing the geojni.cfg file (C:\Program Files\MapInfo\AnySite_AU\geojni.cfg) as shown below:

Sample Detail Report (Postal Areas) Has No Values 
If the Sample Detail Report (Postal Areas) does not generate any values, increase your drive time to 10 minutes. 

Upgrading with Mesh Block Data
This release of AnySite Australia includes a new geography level called Mesh Block.

About the Mesh Block Geography Level
The Australian Bureau of Statistics (ABS) developed Mesh Blocks as a new micro-level geographical unit for statistics. 
There are 314,369 spatial Mesh Blocks covering Australia with most residential Mesh Blocks containing approximately 
30 to 60 dwellings. Mesh Blocks are intended to become a new building block of statistical and administrative 
geography. Usual residence population and total dwellings were made available from the 2006 Census of Population 
and Housing for each Mesh Block.

If you are an upgrade customer and wish to use this new geography level, follow the instructions below to configure 
your current AnySite installation.

Note 2006 Census Usual Residence population and Total Dwellings are the only variables available at the Mesh 
Block level, so they cannot be added to reports or thematics at other levels of geography, and no other 
variables can be added to reports or thematics at the Mesh Block level.
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Adding a Mesh Block Layer
1. Launch the Configurator.
2. Expand the Preferences > Layers folders and select Tables.

3. Click New. 
The Layer dialog appears.

4. In the Name field, type Mesh Block.
5. In the Source section, click Edit.
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6. Locate the AnySite_AU\Data directory. Select the MBAU94BDY.TAB file and click Open.

7. In the Display section of the Layer dialog, click Type. The Type dialog appears.

a. In the Legend Name field, type Mesh Blocks.
b. From the Object Type drop-down list, select Regions.
c. From the Data Source drop-down list, select ABS.
d. From the Geography drop-down list, select Mesh Block.

Note If Mesh Block is not an option in this drop-down list, you must first add it using the Boundary Manager 
(see Adding a Mesh Block Boundary on page 10).

e. In the Enable For section, select Searching On and Reporting On.
f. Click Ok.
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8. At the bottom of the Layer dialog in the Options section, select the options shown below (Selectable and In Layer 
Control) and click OK:

9. Click Address.
The Address dialog appears.

a. From the ID drop-down list, select ID.
b. From the Longitude/X drop-down list, select longitude.
c. From the Latitude/Y drop-down list, select latitude.
d. Click OK.

10. In the Layer dialog, click OK.
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Adding a Mesh Block Boundary
1. Select Tools > Boundary Manager.

The Boundary Manager dialog appears.

2. If Mesh Block does not appear in the list, click Add.
The Boundary dialog appears.

a. In the Geography Level field, type MB.
b. In the Description field, type Mesh Block.
c. From the Select Layer drop-down list, select Mesh Block.
d. In the Centroid Path field, verify the path is:

C:\PROGRAM FILES\MAPINFO\ANYSITE_AU\DATA\CENTROIDS\MBAU94CEN
e. Click OK.
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Editing the AnySite.ini File
1. In the Configurator, select Tools> Edit Application INI File.
2. Locate the StandardGeographyList entry.

3. Verify that the following text string is at the end of the StandardGeographyList entry:
| MB,Mesh Blocks,CD:ID_NAME,FILTER,ST

4. If this Mesh Blocks string does not appear, add it to the end of the StandardGeographyList entry, then save 
and close the anysite.ini file.

5. Open the AnySite Data Manager and verify that Mesh Blocks now appear:
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