
AnySite®

New Zealand
Version 8.8

INSTALL GUIDE



Information in this document is subject to change without notice and does not represent a commitment on the part of the vendor or its representatives. No part 
of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, including photocopying, without the written 
permission of Pitney Bowes Software Inc., One Global View, Troy, New York 12180-8399.

©2008-2010 Pitney Bowes Software Inc. All rights reserved. MapInfo, Group 1 Software, and AnySite are trademarks of Pitney Bowes Software Inc. All other 
marks and trademarks are property of their respective holders.
United States:
Phone: 518.285.6000
Fax: 518.285.6070
Sales: 800.327.8627
Government Sales: 800.619.2333
Technical Support: 518.285.7283
Technical Support Fax: 518.285.6080
pbinsight.com
Asia Pacific/Australia:
Phone: +61.2.9437.6255
Fax: +61.2.9439.1773
Technical Support: 1.800.648.899
pbinsight.com.au
Contact information for all Pitney Bowes Software Inc. offices is located at: http://www.pbinsight.com/about/contact-us.
February 2010

http://www.mapinfo.com
http://www.mapinfo.com/contactus
http://www.mapinfo.com.au


Table of Contents

Chapter 1: Introduction. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
Product Inventory . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .6
About this Guide . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .6

Conventions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .6

Chapter 2: Before You Begin . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
Permissions. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .10
System Requirements. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .10
Default Install Path  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .10
Time/Space Considerations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .11
Installation Scenarios . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .11

Chapter 3: Installing  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
Evaluation Version Users . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .14
Installing to a Local Machine (Single User)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .14

Complete Installation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .18
Custom Installation. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .20

Installing to a Network (Shared by Multiple Users) . . . . . . . . . . . . . . . . . . . . . . . . . . . .22
Complete Network Installation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .26
Custom Network Installation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .28

Installing the .NET Framework. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .32
Installing your Data License File . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .34
Installing the AnySite New Zealand Client . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .35

Launching and AnySite Client Setup Wizard . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .36
Final System Configuration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .38

Launching the Configurator . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .39
Importing Repository Transfer (ART) Files for your Data. . . . . . . . . . . . . . . . . . . . . . . .40
Cataloging System Data if Stored to a Non-Default Location  . . . . . . . . . . . . . . . . . . . .41

Chapter 4: Starting AnySite New Zealand. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43
Logging into and Launching AnySite New Zealand. . . . . . . . . . . . . . . . . . . . . . . . . . . .44
Handling Data Not Found Messages . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .44
Default Locations for Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .45



Table of Contents
Chapter 5: Upgrading Your Current Installation . . . . . . . . . . . . . . . . . . . . . . . . . . 47
Upgrading AnySite New Zealand. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 48
Updating Reports and Thematics . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49

Updating Standard Reports and Thematics. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49
Updating your Custom Reports and Thematics . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50

Upgrading the AnySite New Zealand Client . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52

Chapter 6: Uninstalling  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53
Uninstalling the AnySite New Zealand Application . . . . . . . . . . . . . . . . . . . . . . . . . . . . 54
Uninstalling the AnySite New Zealand Client. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 54

Chapter A: Performance Tuning a Network Installation . . . . . . . . . . . . . . . . . . . . 55
Network Speed  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56
Virus Scanner Software Settings. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56
4 AnySite New Zealand 8.8



1

Introduction
Welcome to AnySite New Zealand. System Administrators installing AnySite 
New Zealand need to read this entire document for a successful installation. 

AnySite New Zealand helps you to analyze the relationship between store 
performance and market trade area demographic characteristics. AnySite New 
Zealand lets you integrate the specific data you need from various sources, so 
that you can connect, retrieve, report on, and map any information from your 
proprietary database to analyze trade area data.

Access to data is controlled using account permissions set through the AnySite 
New Zealand Configurator tool, which is installed with AnySite New Zealand. 
This allows an AnySite Administrator to restrict access to sensitive data.

For information on setting system preferences and defaults through AnySite 
New Zealand’s Configurator tool, refer to the AnySite New Zealand Reference 
after installing AnySite New Zealand.

In this chapter:

Product Inventory. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .6
About this Guide  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .6



Product Inventory
Product Inventory
Your copy of AnySite New Zealand installs the following to your system:

• AnySite New Zealand – Server and client software.
• Data Manager tool – For importing and exporting data from the AnySite Data Engine.
• Configurator tool – For managing AnySite New Zealand system settings.
• Data – Data purchased with AnySite New Zealand for market and site analysis.
• Tutorial data – Sample data provided to follow along with the AnySite New Zealand tutorial.
• Install Guide – This document, which provides installation and system configuration instructions.
• Reference Guide – Provides a reference for working with AnySite New Zealand, and the Data 

Manager and Configurator tools.

About this Guide
This guide is organized as follows:

• Chapter 2: Before You Begin – Requirements and system setup needed.
• Chapter 3: Installing – Instructions for installing the AnySite New Zealand Application.
• Chapter 4: Starting AnySite New Zealand – Instructions on how to log in to and launch 

AnySite New Zealand.
• Chapter 5: Upgrading Your Current Installation – Instructions on how to upgrade your 

existing AnySite New Zealand installation to this new release.
• Chapter 6: Uninstalling – Instructions on how to remove AnySite New Zealand from your 

system.

Conventions
This guide may provide full paths to menu commands. For example, File > Print is the same as “on 
the File menu, click Print”.
6 AnySite New Zealand 8.8



Chapter 1: Introduction
When referring to Configurator preferences the convention of Preferences > Layers > Linked is the 
same as “in the Preferences pane, click Layers, and then click Linked”.
Install Guide 7
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Before You Begin
When installing AnySite New Zealand, it is important to decide your installation 
location, and deployment environment.

Note If you install AnySite New Zealand incorrectly, you may need to 
remove the application from your computer and re-install it to fix any 
problems.

In this chapter:

Permissions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .10
System Requirements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .10
Default Install Path . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .10
Time/Space Considerations  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .11
Installation Scenarios  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .11



Permissions
Permissions
Administrative rights to the program files directory are required for installation. 

Once installed, users need read/write/modify rights to the AnySite.ini and AnySite.mdb files, which 
are located within the AnySite New Zealand application directory. Give users read/write/modify 
rights to the entire AnySite New Zealand application directory.

System Requirements

Default Install Path
The default install path is C:\Program Files\MapInfo\AnySite_XX\Data, where XX is a two-digit 
country code.

Operating System: • Windows XP Service Pack 2 or higher
• Windows 2000 with Service Pack 4 or higher
• Windows Server 2003 (Standard or Enterprise) Service Pack 1

Hardware: • Pentium IV Processor 1.x GHz or better, with 512MB of RAM (1GB 
or better recommended)

• 15-inch monitor, with graphic accelerator card, 16 bit color or 
greater. Minimum of 800x600 resolution is required.

Hard Disk Space: Dependent on the data purchased. Up to 500 MB.

Software: Microsoft Word 2002, 2003, or later (recommended for viewing reports)
10 AnySite New Zealand 8.8



Chapter 2: Before You Begin
Time/Space Considerations
The AnySite New Zealand install wizard installs both the AnySite New Zealand application and data 
(streets, demographics, and geocoder for example). The length of time for the install will range from 
1-4 hours depending on the speed of your media drive and file transfer across a network. The 
installation of AnySite New Zealand cannot be stopped and restarted at a later date. Schedule 
enough time prior to beginning the install process.

The following chart provides an estimation of size needed when installing AnySite New Zealand and 
its corresponding data. The footprint will change depending upon the geography purchased.

You have the option to install the data to a location separate from the AnySite New Zealand 
application. The most common scenario is to install the application and data to the same machine. 

Installation Scenarios
During the install you have the option to perform a Single or a Shared setup type. A Single setup 
type is for a local installation, where a single user installs AnySite New Zealand and the AnySite 
New Zealand Client to a local machine. A Shared setup type is for a network installation where 
multiple users on a network will access AnySite New Zealand.

For questions regarding installation scenarios please contact AnySite New Zealand Technical 
Support via email at asiapac.support@mapinfo.com or +61 7 3844 7744. A free-phone number for 
New Zealand will be provided when a technical support contract is activated.

Local Installation (Single User)

A local installation installs and runs AnySite New Zealand on a single machine. Choose a local 
installation if only a single user is going to access AnySite New Zealand. 

For optimal performance of AnySite New Zealand on a local machine, install the entire application: 
both server and client software.

Name Approximate Disk Space Needed

AnySite New Zealand 
Program

500 MB

Application Data 200 MB

Demographic Data 100 MB

StreetPro 100 MB

MapMarker Server 100 MB
Install Guide 11



Installation Scenarios
Network Installation (Shared by Multiple Users)

A network installation installs AnySite New Zealand (executable and all associated files) onto a 
network of machines. Choose a network installation if multiple users are going to access AnySite 
New Zealand. Install AnySite New Zealand from the console of the server where AnySite New 
Zealand will reside, and install the AnySite New Zealand Client onto each user’s local machine 
where they will run AnySite New Zealand from. 

If you are installing to the network from a local machine, you must have a mapped drive to your 
network location. The mapped drive is only required for the installation process. UNC (Universal 
Naming Convention) paths may be used to run the application from a network. Refer to Final 
System Configuration in Chapter 3 on page 38.
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Installing
To successfully install AnySite New Zealand, read this entire chapter before 
beginning. Refer to Before You Begin in Chapter 2 on page 9 for pre-
installation requirements and planning.

During the installation procedure, you must make some decisions about your 
installation. Please read these instructions before installing, so that your 
installation runs smoothly.

Follow the directions for the Final System Configuration on page 38 after 
completing the main installation. These steps are required for every installation 
and will ensure that your AnySite New Zealand installation is successful.

In this chapter:

Evaluation Version Users  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .14
Installing to a Local Machine (Single User) . . . . . . . . . . . . . . . . . .14
Installing to a Network (Shared by Multiple Users). . . . . . . . . . . .22
Installing the .NET Framework . . . . . . . . . . . . . . . . . . . . . . . . . . . .32
Installing your Data License File  . . . . . . . . . . . . . . . . . . . . . . . . . .34
Installing the AnySite New Zealand Client. . . . . . . . . . . . . . . . . . .35
Final System Configuration. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .38



Evaluation Version Users
Evaluation Version Users
If you currently have an evaluation version of AnySite New Zealand installed on your machine, you 
must uninstall the evaluation version prior to installing the full version.

Installing to a Local Machine (Single User)
To Install AnySite New Zealand onto a local machine:

1. Place the AnySite New Zealand Installation DVD in the media drive.

If the installation does not automatically start, click Run from the Microsoft Start menu, and click 
the Browse button. Go to the media drive and select Launch.exe. 

Select Install, and then select Install AnySite.
14 AnySite New Zealand 8.8



Chapter 3: Installing
2. The Welcome screen displays. 

Click Next to continue.

3. The License Agreement screen displays. 

Carefully read the License Agreement. Select I accept the terms in the license agreement to 
accept the terms of the agreement.

Click Next to continue the installation process.

4. The Customer Information screen displays. 

Enter your name, organization name, and serial number (all three fields are required).
Install Guide 15



Installing to a Local Machine (Single User)
The Serial Number is located on the outside of the AnySite New Zealand box. This number is 
required for the installation to continue. If you are unable to locate your serial number, contact 
your sales representative for assistance (for contact information, see Installation Scenarios in 
Chapter 2 on page 11).

Click Next to continue.

5. The Data Unlocking screen displays. 

Enter your Unlocking Code. The unlocking code is included in the Unlock Code and Serial 
Number document included in the software box. The serial number and unlock code are 
connected to each other, if you receive a message stating your unlock code is invalid, recheck 
your serial number to see if it was keyed in properly.

Click Next to continue.
16 AnySite New Zealand 8.8



Chapter 3: Installing
6. The Setup Type screen displays.

Select Complete or Custom, and then Click Next to continue.

• Complete installs AnySite New Zealand and all of its components.

• Custom lets you select which program features and data to install, and lets you install them 
to different locations either on your hard drive or on a network drive.

If you chose Complete, refer to Complete Installation for further instructions. If you chose Custom, 
refer to Custom Installation on page 20 for further instructions.
Install Guide 17



Installing to a Local Machine (Single User)
Complete Installation
To continue with a Complete installation:

1. The Destination Folder screen displays after clicking Complete in the Setup screen.

Choose This installation is for a single user to install AnySite New Zealand and the AnySite 
New Zealand Client to a local machine.

If you would like to change the default installation location, click Change to browse to a different 
location.

Click Next to continue.
18 AnySite New Zealand 8.8



Chapter 3: Installing
2. The Ready to Install the Program screen displays.

If you chose to deselect desktop icons, then you can launch these features from the Microsoft 
Start menu by clicking Programs > MapInfo > AnySite.

Click Install to begin the Installation process.

Note If the .NET Framework License Agreement screen displays, then you do not have a 
compatible version of Microsoft .NET Framework installed. To complete your installation, 
proceed to Installing the .NET Framework on page 32. 

3. The Installation Complete screen displays.

Click Finish to close the AnySite New Zealand Installation wizard.

4. Complete the installation by rebooting the system. 

After rebooting, continue to Installing your Data License File on page 34.
Install Guide 19



Installing to a Local Machine (Single User)
Custom Installation
This section continues from step 6 in Installing to a Local Machine (Single User) after choosing 
Custom in the Setup screen. The options for a Custom Setup include application files and data. 

You will have the option to select to install AnySite New Zealand features, such as data, to your local 
hard drive or to a network drive. If installing to a network drive, then map the drive first. You may also 
choose not to install a feature.

Note Installing features to a network drive is not the same as installing AnySite New Zealand on a 
network to be shared by multiple users. 

For optimal performance on a local machine, install everything to the local machine.

To continue with a Custom installation:

1. The Destination Folder screen displays after clicking Custom in the Setup screen.

Choose This installation is for a single user to install AnySite New Zealand and the AnySite 
New Zealand Client to the local machine.

If you would like to change the default installation location, click Change to browse to a different 
location.

Click Next to continue.

2. The Custom Setup screen displays.

By default, the wizard installs all features. To deselect a feature, click the feature icon and select 
This feature will not be available. Only selected features install.

Features install to your local hard drive in the folder indicated. To specify a different folder, click 
Change.

Click Next to continue.
20 AnySite New Zealand 8.8



Chapter 3: Installing
3. The Ready to Install the Program screen displays.

If you chose to deselect desktop icons, then you can launch these features from the Microsoft 
Start menu by clicking Programs > MapInfo > AnySite.

Click Install to begin the Installation process.

Note If the .NET Framework License Agreement screen displays, then you do not have a 
compatible version of Microsoft .NET Framework installed. To complete your installation, 
proceed to Installing the .NET Framework on page 32. 
Install Guide 21



Installing to a Network (Shared by Multiple Users)
4. The Installation Complete screen displays.

Click Finish to close the AnySite New Zealand Installation wizard.

5. Complete the installation by rebooting the system. 

After rebooting, continue to Installing your Data License File on page 34.

Installing to a Network (Shared by Multiple Users)
In a shared setup, you install AnySite New Zealand to a single machine in a network of connected 
machines. You then install the AnySite New Zealand Client on to those machines in the network that 
access AnySite New Zealand. 

This section describes how to install AnySite New Zealand. After completing the instructions in this 
section, you will install the AnySite New Zealand Client on to all machines that will access AnySite 
New Zealand. 

Note There is an option to install the AnySite New Zealand Client as part of this main installation if 
the machine used to install to the network location will also be used to run AnySite New 
Zealand.

You must have a mapped drive to your network location and full write permission to the drive to 
install the AnySite New Zealand Client. The mapped drive is only required for the installation 
process.
22 AnySite New Zealand 8.8



Chapter 3: Installing
To Install AnySite New Zealand on a network:

1. Place the AnySite New Zealand Installation DVD in the media drive.

If the installation does not automatically start, click Run from the Microsoft Start menu, and click 
the Browse button. Go to the media drive and select Launch.exe. 

Select Install, and then select Install AnySite.

2. The Welcome screen displays. 

Click Next to continue.
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Installing to a Network (Shared by Multiple Users)
3. The License Agreement screen displays. 

Carefully read the License Agreement. Select I accept the terms in the license agreement to 
accept the terms of the agreement.

Click Next to continue the installation process.

4. The Customer Information screen displays. 

Enter your name, organization name, and serial number (all three fields are required).

The Serial Number is located on the outside of the AnySite New Zealand box. This number is 
required for the installation to continue. If you are unable to locate your serial number, contact 
your sales representative for assistance (for contact information, see Installation Scenarios in 
Chapter 2 on page 11).

Click Next to continue.
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Chapter 3: Installing
5. The Data Unlocking screen displays. 

Enter your Unlocking Code. The unlocking code is included in the Unlock Code and Serial 
Number document included in the software box. The serial number and unlock code are 
connected to each other, if you receive a message stating your unlock code is invalid, recheck 
your serial number to see if it was keyed in properly.

Click Next to continue.

6. The Setup Type screen displays.

Select Complete or Custom, and then click Next to continue.

• Complete installs AnySite New Zealand and all of its components.

• Custom lets you select which program features and data to install, and lets you install them 
to different locations either on your hard drive or on a network drive.
Install Guide 25



Installing to a Network (Shared by Multiple Users)
If you chose Complete, refer to Complete Network Installation on page 26 for further instructions. 
If you chose Customer, refer to Custom Network Installation on page 28 for further instructions.

Complete Network Installation
This section continues from step 6 in Installing to a Network (Shared by Multiple Users) on 
page 22, after choosing Complete in the Setup screen.

To continue with a complete installation:

1. The Destination Folder screen displays.

Choose This installation will be shared by others on a network and do one of the following:

• Accept the default destination folder by clicking Next to install on this local machine.

• Change the destination folder by clicking Change to install to a machine on the network by 
selecting a mapped drive (you will require full write permission to the location). The Change 
Current Destination Folder screen displays to select a location on the network.
26 AnySite New Zealand 8.8



Chapter 3: Installing
2. The Choose Installation Options screen displays.

Deselect the AnySite New Zealand Client option if you do not want to install it on this machine.

Deselect the desktop icon options if you do not want to install them. You can launch these 
features from the Microsoft Start menu by clicking Programs > MapInfo > AnySite.

Click Next to continue.

Note If installing to Windows Server 2003, then the AnySite New Zealand Client separately as 
described in Installing the AnySite New Zealand Client on page 35.

3. The Ready to Install the Program screen displays.

Click Install to begin the Installation process.

Note If the .NET Framework License Agreement screen displays, then you do not have a 
compatible version of Microsoft .NET Framework installed. To complete your installation, 
proceed to Installing the .NET Framework on page 32. 
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Installing to a Network (Shared by Multiple Users)
4. The Installation Complete screen displays.

Click Finish to close the AnySite New Zealand Installation wizard.

5. Complete the installation by rebooting the system. 

You must reboot the system and then continue to Installing your Data License File on page 34.

Custom Network Installation
This section continues from step 6 in Installing to a Network (Shared by Multiple Users) on 
page 22, after choosing Custom in the Setup screen. The options for a Custom Setup include 
application files and data packages. 

When you select a feature in step 3 of the following procedure, a menu displays allowing you to 
choose to install the feature and its sub-features to your local hard drive or a network drive. If 
installing to a network drive, then map the drive for the installation.

Note Installing components to a network drive is not the same as installing AnySite New Zealand 
on a network to be shared by multiple users.

To continue with a Custom installation:

1. The Destination Folder screen displays.

Choose This installation will be shared by others on a network and do one of the following:

• Accept the default destination folder by clicking Next to install on this local machine.

• Change the destination folder by clicking Change to install to a machine on the network by 
selecting a mapped drive (you will require full write permission to the location). The Change 
Current Destination Folder screen displays to select a location on the network.
28 AnySite New Zealand 8.8



Chapter 3: Installing
2. The Choose Installation Options screen displays.

Deselect the AnySite New Zealand Client option if you do not want to install it on this machine.

Deselect the desktop icon options if you do not want to install them. You can launch these 
features from the Microsoft Start menu by clicking Programs > MapInfo > AnySite.

Click Next to continue.

Note If installing to Windows Server 2003, then install the AnySite New Zealand Client 
separately as described in Installing the AnySite New Zealand Client on page 35.
Install Guide 29



Installing to a Network (Shared by Multiple Users)
3. The Custom Setup screen displays.

By default, the wizard installs all features. To deselect a feature, click the feature icon and select 
This feature will not be available. Only selected features install.

Features install on your local hard drive in the folder indicated. To specify a different folder, click 
Change.

Click Next after the custom features have been selected.

4. The Ready to Install the Program screen displays.

Click Install to begin the Installation process.

Note If the .NET Framework License Agreement screen displays, then you do not have a 
compatible version of Microsoft .NET Framework installed. To complete your installation, 
proceed to Installing the .NET Framework on page 32. 
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Chapter 3: Installing
5. The Installation Complete screen displays.

Click Finish to close the AnySite New Zealand Installation wizard.

6. Complete the installation by rebooting the system. 

You must reboot the system and then continue to Installing your Data License File on page 34.
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Installing the .NET Framework
Installing the .NET Framework
This part of the installation occurs when you do not already have a compatible version of Microsoft 
.NET framework installed on your machine. Microsoft .NET Framework version 2.0 is required to run 
AnySite New Zealand. (For information about the Microsoft.NET framework, see 
www.microsoft.com/net.)

1. The Welcome to Microsoft .NET Framework 2.0 Setup dialog displays.

Click Next to continue.
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2. The License Agreement screen displays. 

Carefully read the License Agreement. Select "I accept" to agree to the terms.

Click Install to continue the installation process.

The Installing .net screen displays with a progress bar indicating the status of the installation 
process.
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3. The Installation Complete screen displays.

Click Finish to complete the .NET installation.

You must reboot the system and then continue to Installing your Data License File on page 34.

Installing your Data License File
A unique license ships with your copy of AnySite to give you access to the data you purchased. This 
license is on a license CD that is included with your AnySite New Zealand media.

To Install the data license file:

1. Place the License CD in the media drive.

If the installation does not automatically start, click Run from the Microsoft Start menu, and click 
the Browse button. Go to the media drive and select INSTALL.EXE.

2. In the License Installer screen click Install to copy the license file to the AnySite New Zealand 
installation location (C:\Program Files\MapInfo\AnySite_NZ\Data\ASDE for example).
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3. A Notice dialog displays.

Click OK when prompted that the installation is complete.

If you selected a single user setup installation, continue to Final System Configuration on 
page 38.

If you select a multiple user setup installation or you installed to the Windows 2003 operating 
system, continue to Installing the AnySite New Zealand Client instructions.

Installing the AnySite New Zealand Client
The AnySite New Zealand Client allows a user to access the AnySite New Zealand application.

Single User Installations:

If you selected a Single setup type installation on Windows XP, then you do not have to install the 
AnySite Client. The Client installs by default for you. Skip to Final System Configuration on 
page 38.

If you installed on Windows 2003 server then you must install the Client. Follow the instructions in 
the next section Launching and AnySite Client Setup Wizard on page 36.

Multiple User Installations:

If you selected a Shared (network) setup type, so that multiple users can access AnySite New 
Zealand, then install the AnySite New Zealand Client on each machine that will access AnySite New 
Zealand.

The AnySite Client Installer is a ClientSetup.exe file located under the AnySite installation folder 
(C:\Program Files\MapInfo\AnySite_NZ by default). Map the drive to the AnySite installation folder 
where the user will be running AnySite from, and then run the ClientSetup.exe file from the client 
machine (as described in the next section Launching and AnySite Client Setup Wizard). 

Map a drive on each client machine using the same map drive letter. After running the Client 
installation on each client machine, run the final system setup as described under Final System 
Configuration on page 38.

The mapped drive is only required for the installation process. Use UNC to run the application from a 
network. 

Note The Client setup creates shortcuts pointing to the mapped drive not the UNC.
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Launching and AnySite Client Setup Wizard
To launch the Client Setup wizard to install AnySite New Zealand Client:

1. Locate the ClientSetup.exe file in the folder where AnySite New Zealand is installed. By default, 
AnySite New Zealand installs to C:\Program Files\MapInfo\AnySite_NZ. Double-click on the 
ClientSetup.exe file to launch the Client Setup wizard.

If the Welcome to Microsoft .NET Framework 2.0 Setup screen displays, follow the instructions 
under Installing the .NET Framework on page 32 and then continue with the next step.
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2. The Welcome screen displays. 

Click Next to continue.

3. The Ready to Install the Program screen displays.

Select which desktop Shortcuts to create. (The AnySite New Zealand Configurator requires 
AnySite New Zealand administrative permissions to access.)

Click Install to begin the Installation process. 
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4. The InstallSheild Wizard Completed screen displays once the AnySite New Zealand Client has 
been installed. 

Click Finish to complete the Installation.

The help systems for AnySite and for the Data Manager do not display on AnySite Client machines 
due to a Microsoft network security setting. You must copy the help files to the client machines, so 
that users can open them. Copy the files called MapInfoAnySite.chm and AnySiteDataManager.chm 
files from the AnySite Documentation folder (C:\Program Files\MapInfo\AnySite_NZ\Documentation) 
to the corresponding folder on each client machine.

Proceed to Final System Configuration.

Final System Configuration 
Before launching AnySite New Zealand for the first time, you must complete the steps in the 
following sections:

• Launching the Configurator
• Importing Repository Transfer (ART) Files for your Data
• Cataloging System Data if Stored to a Non-Default Location

These settings are made in the Configurator, which is a utility for managing your AnySite New 
Zealand installation.

If you installed AnySite New Zealand to a network location, so that the AnySite New Zealand Client 
is on a different machine, then perform the steps in each of these sections for each client machine.
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Launching the Configurator
To launch the AnySite New Zealand Configurator and complete the setup of your installation:

1. Either click the AnySite New Zealand Configurator icon on your desktop or click Programs 
> MapInfo > AnySite NZ > AnySite Configurator in the Microsoft Start menu.

2. The Login dialog opens. 

Enter the default user name and password when prompted: type Administrator for the username 
and leave the password blank. Click OK to proceed. Usernames are case sensitive, so make 
sure Administrator has a capital "A".

The Cataloger, a utility accessible from the Configurator, will scan several settings for AnySite 
New Zealand; you may receive a message that the Cataloger will adjust these settings. If at a 
later time you receive this message, then rerun the Cataloger as described under Cataloging 
System Data if Stored to a Non-Default Location on page 41

3. The AnySite New Zealand Configurator opens. 

Proceed to Importing Repository Transfer (ART) Files for your Data.
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Importing Repository Transfer (ART) Files for your Data
After installing your license file, you must import repository transfer (ART) files, which contain 
reports, thematics, and other settings. Reports are data dependent. If you run a report and you have 
not purchased the accompanying data for the report, then a "data not licensed" message displays.

Determine Which ART Files to Import

Use the following table to determine which ART files to import relative to the data you purchased and 
are licensed for. You must import the corresponding ART files using the Configurator.

Note Contact your sales representative with questions about which data bundles you have a 
license for.

Import ART Files Using the Configurator

To import the ART files for your data in the Configurator:

1. Click Tools > Importing Preferences in the AnySite New Zealand Configurator menu.

2. In the Import Preferences dialog, select the *.art file to import (according to the data bundle that 
you purchased, as identified in the preceding table) and then click Open.

You may need to select the Look in list to locate the *.art files the ART Files folder. The default 
location is C:\Program Files\MapInfo\AnySite_NZ\Art Files.

3. In the Select Preferences to Import dialog, select all of the preferences in the list, by pressing the 
Ctrl key, and then click OK.

4. Repeat these steps for each ART file to import (if you have licensed data outside the base 
demographic offering).

You have completed the system configuration and are now ready to launch AnySite New Zealand, 
proceed to Chapter 4: Starting AnySite New Zealand.

If you installed the data supplied with AnySite to a non-default location, then proceed to Cataloging 
System Data if Stored to a Non-Default Location before launching AnySite New Zealand.

MapInfo New Zealand

Bundle ART File

Standard MapInfo New Zealand Standard Bundle.art

StreetPro NZL StreetPro Map Preference.art
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Cataloging System Data if Stored to a Non-Default Location
If the data supplied with AnySite was installed to a non-default location, then configure AnySite New 
Zealand to the location of the data files using the AnySite New Zealand Configurator as described in 
this section.

Shared (network) installations must install the AnySite New Zealand Client before continuing. If you 
have not already done so, see Installing the AnySite New Zealand Client on page 35.

To catalog the data stored in a non-default location, in the Configurator:

1. Click Tools > Cataloger in the AnySite New Zealand Configurator menu.

2. In the Disk Drives to Catalog dialog, check all the drives that contain AnySite New Zealand and 
any additional data for use with AnySite. 

If you installed StreetPro, then select its data directories for cataloging. The default StreetPro 
location is C:\Program Files\MapInfo\Professional X.X\SPXXXX.

If you installed AnySite New Zealand to a network location, so that the AnySite New Zealand 
Client is on a different machine, then select the AnySite New Zealand installation directory 
(which will be a mapped drive). If you could not use the same drive letter when mapping drives 
on the client machines, then you must also select the Use UNC Paths check box. 

Ensure that the Update Layer Paths check box is selected to fix any invalid paths, and then 
click OK.

Note The Update Layer Paths check box updates paths to tables that may be invalid. The Use 
UNC Paths check box records the Universal Naming Convention (UNC) location to the 
data. UNC codes are used in network deployments where consistent network drive 
mappings for each user are not guaranteed. The Cataloger still requires the drives be 
mapped on the machine running the cataloger.

Note You must use the same drive letter for all client installations.
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3. In the Drive Directories dialog, check all the drives that contain AnySite New Zealand data, and 
then click OK.

You have completed the system configuration and are now ready to launch AnySite New Zealand, 
proceed to Chapter 4: Starting AnySite New Zealand. 

Note You must reboot the system before running AnySite New Zealand for the first time.

Run the Cataloger after purchasing additional data sources or when moving data sources, so that 
AnySite New Zealand recognizes the data.
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Starting AnySite New 
Zealand
This chapter describes how to launch AnySite New Zealand.

In this chapter:

Logging into and Launching AnySite New Zealand . . . . . . . . . . .44
Handling Data Not Found Messages  . . . . . . . . . . . . . . . . . . . . . . .44
Default Locations for Data. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .45



Logging into and Launching AnySite New Zealand
Logging into and Launching AnySite New Zealand
If you have not yet run the final system configurations using the Configurator, then you must do so 
first, see Final System Configuration in Chapter 3 on page 38.

Note You must reboot the system before running AnySite New Zealand for the first time.

To start AnySite New Zealand:

1. Either click the AnySite New Zealand icon on your desktop or click Programs > MapInfo > 
AnySite NZ in the Microsoft Start menu.

2. The Login dialog opens.

Enter the default user name and password when prompted: type Administrator for the username 
and leave the password blank. Click OK to proceed. Usernames are case sensitive, so make 
sure Administrator has a capital "A".

Note If you receive a data not found message, then proceed to Handling Data Not Found 
Messages.

AnySite New Zealand opens. Refer to the Tutorial section in the AnySite New Zealand Reference for 
an overview of how to work with AnySite New Zealand.

Handling Data Not Found Messages
The first time you launch AnySite New Zealand, you may be prompted to locate data files if they are 
installed to a non-default location.

Drive Time Data Not Found

When launching AnySite New Zealand the first time, you may get a Drive Time Data Not Found 
message regarding the location of the Drive Time Data. Use the Browse button in the message 
dialog to navigate to the proper directory (C:\Program 
Files\MapInfo\AnySite_NZ\Data\AGS\Freeway for example) and then click OK to close the dialog.
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MapMarker Data Not Found

When launching AnySite New Zealand the first time, you may get several MapMarker Data Not 
Found messages regarding the location of the MapMarker address data. This means that AnySite 
New Zealand does not have the correct path to your geocoder data. Use the Browse button in the 
dialog to navigate to the proper directories, and then click OK.

Default Locations for Data
The following are default locations for data products:

• OEM Marker component of AnySite New Zealand: 
C:\Program Files\MapInfo\AnySite_NZ\Data\MapMarker\Data

• MapMarker installed to a non-default location. If prompted for the locations of files, then refer to 
the following. These files will be located under your MapMarker installation directory.

MM 10.5 Default Path

jvm.dll ...\JRE\bin\client

mmjnzlc.jar ...\sdk\engine\lib\client 

mmjnzls.jar ...\sdk\engine\lib\server 

miutil.jar ...\sdk\engine\lib\common 

geoinfo.jdr ...\data\Str_dict

nzl.jdr ...\data\Str_dict

postinfo.jdr ...\data\Str_dict
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46 AnySite New Zealand 8.8



5

Upgrading Your Current 
Installation
Depending on your data provider, your demographic content may be updated 
one to four times a year. Updated templates for all Standard reports, Thematics, 
Hotspots, and Capture Methods are provided with each demographic update.

In this chapter:

Upgrading AnySite New Zealand  . . . . . . . . . . . . . . . . . . . . . . . . . .48
Updating Reports and Thematics . . . . . . . . . . . . . . . . . . . . . . . . . .49
Upgrading the AnySite New Zealand Client. . . . . . . . . . . . . . . . . .52



Upgrading AnySite New Zealand
Upgrading AnySite New Zealand
To upgrade from the previous release:

1. Place the AnySite New Zealand Installation DVD in the media drive.

If the installation does not automatically start, click Run from the Microsoft Start menu, and click 
the Browse button. Go to the media drive and select Launch.exe. 

Select Install, then select Install AnySite.

2. The InstallShield Installer Update Completed screen displays.

Click Continue.

3. A prompt to upgrade your AnySite application and data displays.

Click Yes.
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4. The Welcome screen displays. 

Click Next to continue.

Follow the installation directions that match your current deployment (local or network). When 
prompted, check the installation path to make sure you are upgrading the desired AnySite New 
Zealand installation. 

After completing the install and final system configuration, continue with the directions under 
Updating Reports and Thematics on page 49 to update your custom reports and thematics.

Updating Reports and Thematics
If you are upgrading demographic data, then the existing standard reports (Summary, Detail, 
Comparative, and Quick View), thematics (Shades, Hotspots and Dot Densities), and Capture 
Methods in your AnySite New Zealand now need to be updated. Changes made by your 
demographic data provider may prevent the existing data from functioning properly within AnySite 
New Zealand. 

Updating Standard Reports and Thematics
To change the vintage on standard reports:

1. Launch the AnySite New Zealand Configurator. Either click the AnySite New Zealand 
Configurator icon on your desktop or click Programs > MapInfo > AnySite NZ > AnySite 
Configurator from the Microsoft Start menu.

Enter the default user name and password when prompted: type Administrator for the username 
and leave the password blank. Usernames are case sensitive, so make sure Administrator has a 
capital "A".

Click OK to proceed. 
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Updating Reports and Thematics
2. Click Tools > Import Preferences. 

3. Navigate to the ART Files folder under the AnySite installation folder (C:\Program 
Files\MapInfo\AnySite_NZ\Art Files for example).

4. Select the most recent .ART file. 

5. Highlight all items, and click OK. 

The Configurator is updated with the new reports and thematics that correspond with the data.

6. Repeat from step 3 for all the new/updated ART files.

Note A detailed electronic copy of exporting and importing preferences directions is provided on 
the AnySite New Zealand Installation disk under Upgrade\Documentation.

Updating your Custom Reports and Thematics
It will only be necessary for you to manually update the "Verbose" descriptions on reports, 
thematics, Hotspots, and Capture Methods that you have customized. The underlying demographic 
content (numbers) are automatically updated by the AnySite New Zealand installer, the "Verbose" 
descriptions (2004 Total Population) will have to be manually altered from 2004-2005 via the 
Configurator. 

All reports, thematics, Hotspots, and capture methods will continue to run successfully using the 
newest content from the installer. However, without importing the updated "Standard" reports and 
modifying the "verbose" descriptions on your custom reports, the printed maps and reports will 
continue to display the previous data vintage.

To change the vintage on custom reports:

1. Launch the AnySite New Zealand Configurator. Either click the AnySite New Zealand 
Configurator icon on your desktop or click Programs > MapInfo > AnySite NZ > AnySite 
Configurator from the Microsoft Start menu.

Enter the default user name and password when prompted: type Administrator for the username 
and leave the password blank. Usernames are case sensitive, so make sure Administrator has a 
capital "A".

Click OK to proceed. 

2. On the Preferences menu, click Reports. 

3. Select your custom report, and click Edit.
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4. Select a variable and modify the verbose descriptions. Click OK when you have finished.

Some of your existing thematics and reports may continue to run, but the verbose vintage 
descriptions, such as 2004, will be incorrect, or you may see NOT LICENSED on your reports. 
These variables will need to be manually replaced with the newly updated data. To do this:

1. In the Configurator from the Tools menu, click Update Preferences. 

2. In the Update Preferences dialog, type the vintage description in to the Search For box.

3. Select the found items to update and move them to the Replace With list by clicking the right 
arrow button. 

4. In the Replace With box, type the new vintage description and then click OK.
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Upgrading the AnySite New Zealand Client
To upgrade the AnySite Client software, run the ClientSetup.exe file located in the AnySite 
installation folder (C:\Program Files\MapInfo\AnySite_NZ for example). 

Network clients need to be uninstalled from the client machine and reinstalled to guarantee a correct 
update to the system. Follow the directions under Installing to a Network (Shared by Multiple 
Users) in Chapter 3 on page 22.

AnySite New Zealand integrates data from several third party data vendors. There may be times 
when changes to the data will affect AnySite New Zealand functionality. In some cases, the best 
option will be to install a new version of the application, with the new data. We are continuously 
working with our vendors to establish consistent releases of the various data products to minimize 
these occurrences.
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Uninstalling
To uninstall your AnySite New Zealand software, follow the instructions 
provided here.

In this chapter:

Uninstalling the AnySite New Zealand Application  . . . . . . . . . . .54
Uninstalling the AnySite New Zealand Client  . . . . . . . . . . . . . . . .54



Uninstalling the AnySite New Zealand Application
Uninstalling the AnySite New Zealand Application
To uninstall the AnySite New Zealand application, click Start > Settings > Control Panel > Add or 
Remove Programs and select AnySite New Zealand. Click Remove for this application. A prompt 
displays asking if you would like to remove AnySite New Zealand from your computer. Click Yes to 
proceed with the uninstall.

You are then prompted if you would like to remove all user files from the application directory. 
Selecting Yes removes the entire application directory and all contents of that directory. This 
includes any files you may have created in the AnySite New Zealand directory, such as saved sites, 
custom location or boundary layers. By selecting No, only the Sites, and Art Files directories are left 
untouched.

Once the installer completes, AnySite New Zealand is removed from your system.

Uninstalling the AnySite New Zealand Client
To Uninstall the AnySite New Zealand Client, click Start > Settings > Control Panel > Add or 
Remove Programs and select AnySite New Zealand Client. Click Remove for this application. You 
are prompted if you would like to remove the AnySite New Zealand Client from your computer. Click 
Yes to proceed with the uninstall.

Once the installer completes, the AnySite New Zealand Client will be removed from your system.
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Performance Tuning a 
Network Installation
If you selected a Shared setup type, so that multiple users can access AnySite 
New Zealand, then consider tuning your installation to improve AnySite 
performance.

In this chapter:

Network Speed . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .56
Virus Scanner Software Settings . . . . . . . . . . . . . . . . . . . . . . . . . .56



Network Speed
Network Speed
Using a 100 Megabit network connection is optimal. Using a slower network connection affects the 
refresh rate when panning or refreshing the map view.

Virus Scanner Software Settings
AnySite performance slows when virus software scans AnySite data. The performance decrease is 
noticeable with a network installation when multiple people access AnySite.

AnySite opens many data layers for display in the map view. A data layer consists of five files that 
AnySite launches to display the layer. There may be 16 to 19 layers on display in the map view. 
AnySite queries all of the layer files when you pan or refresh a map.

To improve performance, set the virus software to exclude the AnySite data directory from the virus 
scan (the C:\Program Files\MapInfo\AnySite_NZ\Data directory for example), or to exclude the 
following file type extensions from the virus scan:

• .tab – A MapInfo table file that describes the format of the data.
• .dat – A file containing tabular data.
• .map – A file that describes the graphic objects.
• .id – A cross reference file that links the data with the graphic objects.
• .ind – An index file for searching for map objects.
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