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Installing this Maintenance Release
Your computer must be connected to the Internet to download the 10.0.1 
Maintenance Release.

You may install this Maintenance Release provided one of the following products 
is already installed:

• MapInfo Professional 10.0
• MapInfo Professional Runtime 10.0

If you have more than one of these products installed, the installer upgrades them 
at the same time. You do not need to run this installer multiple times. 

Note You cannot uninstall this Maintenance Release after installing it.

To upgrade MapInfo Professional with this Maintenance Release:

1. Create a temporary folder on your hard drive, such as C:\temp\MIPro10patch.
2. From the MapInfo Professional Main menu, select Help > Check for Update. 

The Maintenance Releases for MapInfo Professional web page displays.
3. On the web page, click the download link to display the File Download dialog 

box.
4. Choose the Save button and save the file to the temporary folder you created 

in step 1. 
5. After the download is complete do the following for your operating system:

• Windows XP, 2003, 2008– double-click the executable file to start the 
installation process. 

• Vista, Windows 7 – right-click the executable file and select Run as 
Administrator from the popup menu to install using elevated privileges. A 
prompt for permission to continue displays. Click Allow or Yes to proceed 
(if you do not respond and the message times-out, the install is 
unsuccessful).

It is important to wait until the installation completes.

http://www.pbinsight.com
http://www.pbinsight.co.uk
http://www.pbinsight.com.au


Note The Japanese version of this executable file, which is labeled as 10.0.1 and includes the Japanese Geocoder 
enhancement, installs as version 10.0.2. After launching MapInfo Professional for Japan, you will see version 
10.0.2 on the product splash screen.

Troubleshooting Error Messages during Installation

Message: Either the Print Service is not running on your computer or this setup can not determine 
the state...

If you see the following message, then the install was unable to upgrade the MapInfo PDF Printer. 

Either the Print Service is not running on your computer or this setup can not determine the state of the Print 
Spooler service. In order to upgrade the MapInfo PDF Printer, start the Print Spooler service and then restart 
the installer.

The upgrade is unsuccessful when the Print Spooler is in a suspended state, such as stopped, pending, or paused. 
Have your System Administrator start the Printer Spooler service on the machine and then re-run the install to 
complete the upgrade.

Message: The feature you are trying to use is on a network resource that is unavailable.

If you see the following message, then the install was run on Vista or Windows 7 without elevated privileges.

The feature you are trying to use is on a network resource that is unavailable.

Re-run the install using elevated privileges, either:

• Right-click the executable file and select Run as Administrator from the popup menu to install using elevated 
privileges. A prompt for permission to continue displays. Click Allow or Yes to proceed (if you do not respond and 
the message times-out, then the install is unsuccessful).

• Have your System Administrator re-run the install, because your account does not have the necessary privileges.

Supported Operating Systems
MapInfo Professional 10.0.1 supports the following operating environments:

• Windows XP Professional SP3
• Windows 2003 Server Enterprise SP1
• Windows 2003 Server Enterprise SP1 with Citrix Presentation Server 4.5
• Windows 2008 Server
• Windows Vista Ultimate SP1
• Windows Vista Ultimate 64-bit with 32-bit compatibility mode
• Windows 7 Ultimate
• Windows 7 Ultimate 64-bit with 32-bit compatibility mode

The Microsoft ACE Engine does not install on Windows 7

The ACE engine, supplied with MapInfo Professional 10.0, lets you open Excel 2007 and Access 2007 files when 
selecting File > Open in MapInfo Professional. The Microsoft ACE Engine does not install with MapInfo Professional 
10.0 on Windows 7, because the ACE engine is not supported on Windows 7. 

Opening an Excel 2007 or Access 2007 file in MapInfo Professional on Windows 7 displays a “Windows cannot open 
this file” message, and MapInfo Professional may close unexpectedly.

To work around this issue, install Microsoft Office 2007 or go to the Microsoft web site to download and install the 
Microsoft ACE Engine. You may do this either before or after installing MapInfo Professional 10.0 and 10.0.1.

http://www.microsoft.com/downloads/details.aspx?FamilyID=7554F536-8C28-4598-9B72-
EF94E038C891&displaylang=en
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Advanced Installation for System Administrators
This section is for the system administrator installing this Maintenance Release using a commandline, and the network 
system administrator installing this Maintenance Release across the network using a Microsoft Patch (MSP) file.

Upgrading in Silent Mode
On Vista and Windows 7, install this Maintenance Release with elevated privileges. To do this, right-click on the 
Command-Line Interpreter (cmd.exe) and select Run as Administrator from the popup menu, then continue with the 
following instructions.

To run the MapInfo Professional Maintenance Release installer in silent mode, from the command prompt, navigate to 
the containing folder for the maintenance release file and type:

MapinfoProfessional10.0.1MaintenanceRelease.exe /s /v"SILINST=True"

Where:
/s = runs the setup.exe silently
/v = passes the parameter "SILINST=True" into the setup.exe to suppress the GUI

Note When running this .exe file, do not use other parameters, such as /qb and /qn, or the upgrade may fail.

On Vista and Windows 7, a prompt for permission to continue displays. Click Allow or Yes to proceed (if you do 
not respond and the message times-out, then the install is unsuccessful).

You will see a progress dialog during the installation. If a Print Service error message displays, see Message: Either 
the Print Service is not running on your computer or this setup can not determine the state... on page 2.

Note The Japanese version of this executable file, which is labeled as 10.0.1 and includes the Japanese Geocoder 
enhancement, installs as version 10.0.2. After launching MapInfo Professional for Japan, you will see version 
10.0.2 on the product splash screen.

Upgrading Using a MSP File
The MapInfo Professional Maintenance Release installer MSP file updates the English version of MapInfo Professional 
10.0. It does not update other language versions, MapInfo Professional Runtime, or the MapInfo PDF Printer. After 
running the MSP file, you must run an additional install file to upgrade the MapInfo PDF Printer.

Both the MSP file and the MapInfo PDF Printer upgrade file are available on request from Technical Support, see 
http://www.pbinsight.com/support/contact-support.

On Vista and Windows 7, install this Maintenance Release with elevated privileges. To do this, right-click on the 
Command-Line Interpreter (cmd.exe) and select Run as Administrator from the popup menu, then continue with the 
following instructions.

Part 1: Upgrading MapInfo Professional 10.0 software

To run the Maintenance Release installer MSP file, type:

msiexec /p <path to the MapinfoProfessional10.0.1MaintenanceRelease.msp file> /qb

Where:
/p = path to the MapinfoProfessional10.0.1MaintenanceRelease.msp file (include file name in path)
/qb = to see a progress dialog at the end of the installation

On Vista and Windows 7, a prompt for permission to continue displays. Click Allow or Yes to proceed (if you do 
not respond and the message times-out, then the install is unsuccessful).

After the MSP install completes, upgrade the MapInfo PDF Printer.
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Part 2: Upgrading the MapInfo PDF Printer

From the command prompt, navigate to the containing folder for the MapInfo PDF Printer upgrade file and type:

UpgradeMapInfoPDFPrinter.exe

On Vista and Windows 7, a prompt for permission to continue displays. Click Allow or Yes to proceed (if you do 
not respond and the message times-out, then the install is unsuccessful).

Note If a Print Service error message displays, see Message: Either the Print Service is not running on your 
computer or this setup can not determine the state... on page 2.

You can do this in silent mode, with a basic user interface, by typing:

UpgradeMapInfoPDFPrinter.exe /s /v"SILINST=True"

Where:
/s = runs the setup.exe silently
/v = passes the parameter "SILINST=True" into the setup.exe to suppress the GUI

Note When running this .exe file, do not use other parameters, such as /qb and /qn, or the upgrade may fail.

New in this Maintenance Release

Toolbar and Menu Changes

Toolbar Position
• Fixed calculations for docked toolbar position
• Support for negative row numbers when a toolbar is positioned above the menu bar

Related MapBasic updates affect the following:

• Create ButtonPad ToolbarPostion(row, col)
• Alter ButtonPad ToolbarPostion(row, col)

Reset Toolbars
• Restores all system toolbars to their default state as defined by mapinfow.mnu
• Restores toolbar if destroyed using Alter ButtonPad Destroy
• Restores toolbar if renamed using Alter ButtonPad Title

Related MapBasic updates affect the following:

• Create ButtonPads as Default
• Create ButtonPad as Default

New MapBasic Capability for Custom Icons

Before MapInfo Professional 10.0, custom icons were rectangular in size: 18x16 for small icons and 26x24 for large 
icons. New toolbar and menu features introduced in MapInfo Professional 10.0 require square icons: 16x16 for small 
icons and 24x24 for large icons. MapInfo Professional 10.0 displays custom icons in the square size distorting how 
they display. This maintenance release, corrects the distortion by removing the first and last column of pixels to not 
display them (cropping the image). As a result, there may be some loss of information in the icon image.

For best results, recreate your icons to 16x16 for small icons and 24x24 for large icons. Icons at these sizes are not 
backwards compatible and generate an error message in versions earlier than 10.0.1.

For backwards compatibility, use 18x16 for small icons and 26x24 for large icons. These icons appear distorted in 
version 10.0 and appear cropped in later versions.
MapInfo Professional 10.0.1 Maintenance Release Notes 4



About Icons for Menu Items

The following describe how MapInfo Professional handles icons for menu items as of version 10.0:

• Icons for menu items are dynamic based on icons in toolbars.
• If a toolbar button has an icon it may be used for a menu item if it meets one of the following requirements:

• Toolbar button and menu item must be within the same MBX file.
• The same handler/userId combination; any menu item that calls the same handler/userid from the same MBX 

file is assigned that icon).
• The same userId calling different handlers.
• The same handler, no userID.
• ID must be <= 32767.

• For built in handlers, priority is given to find an icon from a built in toolbar. If none is found, then there is a search 
through the toolbar icons from the MBX files for a match.

• Small icons are shown next to menu items. 
• When an MBX unloads, any of its associated icons are unloaded and are no longer in use for menu items.

The following describe how MapInfo Professional handles icons for menu items as of this version:

• There is no icon for the Table > Drive Regions menu option, because there is no corresponding toolbar button for 
this option. There is an icon and toolbar button for the Objects > Driving Regions menu option.

• Other menu items can now show an icon if a MapBasic application creates a toolbar button and menu item that 
meet the previously listed requirements for menu item icons.

Change in Behavior for WindowInfo( ) MapBasic Function with Toolbars

In past versions of MapBasic, using the WindowInfo( ) function with toolbars generates miscellaneous information that 
does not apply, or is not usable with, a  toolbar window (such as when querying a toolbar window for printer information 
or snap mode). The WindowInfo( ) funtion now returns an error message in this situation.

The WindowInfo( ) function returns valid information for the following attributes: WIN_INFO_NAME, WIN_INFO_TYPE, 
WIN_INFO_WIDTH, WIN_INFO_HEIGHT, WIN_INFO_X, WIN_INFO_Y, WIN_INFO_TOPMOST, WIN_INFO_STATE, 
WIN_INFO_OPEN, WIN_INFO_WND, WIN_INFO_WINDOWID, WIN_INFO_SYSMENUCLOSE. For other attributes, 
it generate the message "Cannot perform this operation on this window." 

Object Processing Improvements
There are some performance improvements to some object processing operations, primarily involving Erase and Split. 
These changes relate to how MapInfo Professional writes target objects that fall outside the bounds of the cutter 
objects. The change does not affect target objects that intersect the bounds of cutters and how they are processed. 
The overall performance improvement depends on the data sets in use.

Coordinate System Transformation Improvements for the UK
This release significantly improves the accuracy of the coordinate system conversion between WGS 84 (and 
EUREF89) based coordinate systems and British National Grid. This improvement is achieved by using the NTv2 
datum conversion algorithm between OSGB36 and WGS 84(and EUREF89) datum.

If you need to disable this NTv2 datum conversion, open the ntv2.xml file in the MapInfo application folder and make 
the following entries "false".

<NTv2Conversion>
      <Description>NTv2 Conversion for UK</Description>
      <GridFile>england-wales.gsb</GridFile>
      <Enabled>true</Enabled>
      <SourceDatum>
        <DatumID>79</DatumID>
      </SourceDatum>
      <DestinationDatum>
        <DatumID>104</DatumID>
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      </DestinationDatum>
</NTv2Conversion>
<NTv2Conversion>
      <Description>NTv2 Conversion for UK</Description>
      <GridFile>scotland.gsb</GridFile>
      <Enabled>true</Enabled>
      <SourceDatum>
        <DatumID>79</DatumID>
      </SourceDatum>
      <DestinationDatum>
        <DatumID>104</DatumID>
      </DestinationDatum>
</NTv2Conversion>
<NTv2Conversion>
      <Description>NTv2 Conversion for UK</Description>
      <GridFile>england-wales.gsb</GridFile>
      <Enabled>true</Enabled>
      <SourceDatum>
        <DatumID>79</DatumID>
      </SourceDatum>
      <DestinationDatum>
        <DatumID>115</DatumID>
      </DestinationDatum>
</NTv2Conversion>
<NTv2Conversion>
      <Description>NTv2 Conversion for UK</Description>
      <GridFile>scotland.gsb</GridFile>
      <Enabled>true</Enabled>
      <SourceDatum>
        <DatumID>79</DatumID>
      </SourceDatum>
      <DestinationDatum>
        <DatumID>115</DatumID>
      </DestinationDatum>
</NTv2Conversion>

Known Issues and Workarounds

Change to the Asia-Pacific Contact Information for Technical Support
In the MapInfo Professional Help System, the telephone contact information for Technical Support for Asia-Pacific has 
changed. To contact a Technical Support representative use the following contact information:

Displaying the Layer Control in an Integrated Mapping Application
Integrated Mapping applications cannot display the Layer Control as a window.  However, Integrated Mapping 
applications can display the Layer Control as a modal dialog box, by using the Run Menu Command statement with 
command M_MAP_LAYER_CONTROL_DIALOG (801).  For example: 

Run Menu Command 801

Asia-Pacific Phone: 1800 648 899

Fax: +61 02.9923.6141

ozsupport@mapinfo.com

Monday - Friday from 8 am to 6 pm 
Australian EST, excluding company 
Holidays.
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Translucent Labels Transferred to the Cosmetic Layer do not Retain Translucency 
The labeler tool (Labeler.MBX) in MapInfo Professional transfers labels from a layer in the current map window to its 
cosmetic layer. If the labels are translucent, their translucency is not retained once they become cosmetic layer 
objects. This is because MapInfo Professional does not support per object translucency, and does not automatically 
apply the source label translucency factor to the destination layer.

To retain translucency, set the Cosmetic layer's object translucency before transferring the labels. When MapInfo 
Professional transfers labels they convert to text objects. There are two types of translucency settings per layer—one 
for layer objects (used to draw layer features like regions, lines, text objects) and a separate setting for the layer's 
labels. In this case, the labels are translucent but the Cosmetic layer is not; when the labels are converted to text 
objects, they take on the object translucency of the Cosmetic layer. If the Cosmetic layer object's translucency is zero 
(0), then the labels no longer appear translucent. 

Opening an Excel 2007 Table in MapInfo Professional

Displays Incorrect Date 

By default, Microsoft Excel for Windows uses the 1900 date system and Microsoft Excel for the Macintosh uses the 
1904 date system. If copying and pasting a date time field into a Microsoft Excel for the Macintosh table and then 
opening that table in MapInfo Professional (which runs on a Windows system), then the date may be incorrect by four 
years and one day.

This issue occurs when the Excel for the Macintosh table is set to use the 1904 date system, because MapInfo 
Professional uses the Microsoft Windows 1900 date system. As a result, there is a discrepancy when viewing the table 
in MapInfo Professional. 

To resolve this issue, set the Excel for the Macintosh workbook or template to not use the 1904 date system:

1. Open the workbook or template in Excel 2007.
2. Click the Microsoft Office Button and then click Excel Options.
3. In the Excel Options dialog, select the Advanced tab.
4. Scroll to the When calculating this workbook category and uncheck the Use 1904 date system check box.
5. Click OK to save the change.

The dates in this table now view correctly in MapInfo Professional. 

Note The dates in this table no longer view incorrectly when you open this table in Microsoft Excel for the Macintosh 
unless you reset the file to use the 1904 date system. For more information about the date systems, see the 
Microsoft web site at http://support.microsoft.com/kb/214330.

Does not treat Mixed Data Type Columns as Text

When working with an Excel 2007 table in MapInfo Professional if there are mixed types of data in one column, such 
as float, text, date, and time, then MapInfo Professional treats all the data in the column as text. If MapInfo Professional 
treats the data type of the column as something other than text, then you can correct this by updating a Microsoft ACE 
(Access Connectivity Engine) registry key.

MapInfo Professional detects when an Excel 2007 table has a column with mixed data types, because of the ACE 
setting in the registry. This registry key is called ImportMixedTypes and is located in the registry under HKEY_LOCAL_
MACHINE\SOFTWARE\Microsoft\Office\12.0\Access Connectivity Engine\Engines\Excel. It decides how to import 
mixed data and by default it is set to a text value. A secondary registry key called TypeGuessRows determines how 
many rows to scan for each column before the ACE decides that a column has mixed data types. A value of zero (0) 
scans all the rows to determine if a column has mixed data types; the default setting is eight (8) to scan eight rows. 
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To ensure that the data types of all columns are detected correctly, change the TypeGuessRows key in the registry to 
zero (0). Note that scanning all of the rows in a large spreadsheet can be slow. To edit the registry, you will need 
Administrator privileges. If you do not have the required privileges, then ask your System Administrator to assist you. 

Note WARNING: This is not a MapInfo-specific setting. Changing the TypeGuessRows setting affects all applications 
that use ACE to open Excel files, such as Microsoft Access.

Note The column data types can be overridden through the Set Field Properties dialog box when opening the 
spreadsheet in MapInfo Professional.

Before modifying the TypeGuessRows key in the registry, make a backup:

1. Close any programs that are running. 
2. Choose Start > Run and type the command regedit. Click OK to display the Registry Editor window.
3. In the HKEY_LOCAL_MACHINE entry, navigate to Software > Microsoft > Office > 12.0 > Access Connectivity 

Engine > Engines > Excel.
4. Highlight the Excel folder and then select File > Export.
5. In the Export Registry File dialog, specify a location and file name to backup to and then click Save.
6. Continue to the next set of instructions to set the TypeGuessRows key.

To set the TypeGuessRows key:

1. Select TypeGuessRows and on the Edit menu click Modify to display the Edit DWORD Value dialog box.
2. In the Value data field, type 0 (zero) and click OK.

This option takes effect the next time you open MapInfo Professional.

Improving Performance when Connecting to a SQL Server Database 
To improve performance when accessing large SQL Server tables, add a Multiple Active Result Sets (MARS) 
connection setting to the connection string in the live access .TAB file. The connection attribute to update is 
\DATALINK\ConnectionString, for example:

"\DATALINK\ConnectionString" = "DSN=local-native10;UID=username;
Trusted_Connection=Yes;APP=MapInfo Professional®;
WSID=hostname;DATABASE=test;MARS_Connection=Yes;"

You may also add the MARS connection setting to the connection string of MapBasic Server_Connect( ) command.

Note that a MARS connection:

• does not work for SpatialWare tables.
• only applies to SQL Native Client or SQL Server Native Client 10. Other connection types so not benefit from this 

setting.

INNER JOIN or JOIN Queries Cause a Syntax Error 
MapInfo Professional is unable to process an INNER JOIN or JOIN query to an ODBC table when the table is 
mappable. As a workaround, use the WHERE clause instead of using INNER JOIN or JOIN to join two tables. For 
example:

SELECT t1.c1, t2.c2 FROM t1 INNER JOIN t2 ON (t1.c1 = t2.c2)

May be modified to: 
SELECT t1.c1, t2.c2 FROM t1, t2 WHERE t1.c1 = t2.c2

If there are conditions in the WHERE clause, then use AND to JOIN conditions. For example:

SELECT t1.c1, t2.c2 
FROM t1 INNER JOIN t2 ON (t1.c1 = t2.c2) 
where t1.c1 > 2 or t2.c2 < 100
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May be modified to: 
SELECT t1.c1, t2.c2 
FROM t1, t2 
WHERE t1.c1 = t2.c2 AND (t1.c1 > 2 or t2.c2 < 100)

MapBasic Change to Enabling/Disabling the Close Button on a Toolbar
MapBasic users can change the state of the Close button on a toolbar by using the Set Window SysMenuClose On/Off 
statement and can query its state using the WindowInfo( ) function. 

This version, has a change in behavior from previous versions. In previous versions you could enable or disable the 
Close button regardless of the toolbar’s floating or docking state. In this version, you cannot enable or disable the 
Close button when the toolbar is docked. You can only change the state when it is floating or floating and hidden.

Progress and Resolution of Outstanding Issues
Issues addressed are organized by the following categories:

• MapInfo Professional
SQL Server, PostGIS, and Oracle on page 12
MapInfo PDF Printer on page 12
Layer Control on page 13

• EasyLoader
• MapBasic

Working with Layers in MapBasic on page 18

MapInfo Professional
In some cases, MapInfo Professional 10.0 and older had broken license issues. This issue is resolved.

Issue Description and Resolution

C15797 When ArcGIS® 9.2 or 9.3 is installed on the machine MapInfo Professional closes unexpectedly when 
opening a Universal Data File.

Resolution: Issue is resolved.

IN12888, 
T29596

MapInfo Professional is unable to read a table from a Web Feature Service (WFS) when either "choice" 
or "ref" is a substring of a column name.

Resolution: Issue is resolved.

S10048  One of the North Arrow Symbol styles is missing. 

Resolution: Issue is resolved.

T25485 A workspace that contains a Seamless layer and sample USA data takes minutes to open.

Resolution: Combining tables may affect the default bounds of the map window and, therefore, the 
number of component tables loading the first time map displays. MapInfo Professional now includes an 
optimization for these cases.

T27132 Only the first letter of labels display for some streets with Curved Labels set to on. (This affects polyline 
data that has many nodes.)

Resolution: Issue is resolved.
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T27308 Artifacts remain on the map window, being drawn with Enhanced Rendering, after dragging another 
application window across it.

Resolution: Issue is resolved.

T27656 When exporting a map image in Japanese for use in Google Earth®, and the output file has Japanese 
characters, the resulting raster linked KML file does not open.

Resolution: Issue is resolved.

T28070, 
T28246

Opening a large JPEG 2000 file cause MapInfo Professional to close unexpectedly.

Resolution: Issue is resolved.

T28136 Opening a Shape file that has two points using the Open > File menu option does not import the correct 
coordinates from the second point.

Resolution: Issue is resolved.

T28186 Exporting a map image for use in Google Earth® displays an invalid character message. Opening the 
resulting KML export file in Google Earth displays the message “not well-formed (invalid token)”.

Resolution: Issue is resolved. 

T28564 The Edit > Undo menu option does not show the action to undo, such as Undo Move.

Resolution: Issue is resolved.

T28611 After displaying the map context menu, by right clicking a reparented map window, you cannot dismiss 
the map by clicking elsewhere in the application.

Resolution: Issue is resolved by automatically closing the context menu when the user moves the 
mouse outside the reparented window.

T29127 The Hotlink alias expression text is shown in the popup window and not the evaluated expression. If the 
alias expression of a hotlink is literal text, such as "Baseball" (meaning that no table columns are 
involved in the expression), then the text is shown in the popup window rather than the evaluated 
expression.

Resolution: Issue is resolved.

T29135 The Query > Select All menu option does not show the layer name that the Select All applies to, such as 
“Select All from Highways” where Highways is the layer name.

A Select All applies to the topmost selectable layer in the Layer Control list. It may be difficult to locate 
the topmost layer if there are many layers in the Layer Control list. The Select All menu option now 
shows the layer that the Select All applies to.

Resolution: Issue is resolved.

T29144 The following menu options do not always show the ellipsis (...) to indicate that a dialog opens after 
clicking the option:

• Window > New Browser Window
• Window > New Map Window
• File > Revert Table

Resolution: Issue is resolved.

T29218 Selecting the Help button from some dialogs when the Help window is already open freezes the Help 
window, so that you cannot move the window, scroll the content, or select tabs.

Resolution: Issue is resolved. 

Issue Description and Resolution
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T29390 When using MapInfo Professional as an automation server, an integrated mapping application should be 
able to make MapInfo Professional’s main window visible via the COM interface. For example:

Set MapInfo = CreateObject("MapInfo.Application")
MapInfo.Visible = True

When MapInfo Professional’s main window is visible, its menu bar and toolbars should also be visible. In 
version 10.0 the toolbars are not shown.

Resolution: Issue is resolved. Also, the menu and toolbar state for layout (positions and docked states) 
save to a separate XML file, called MICommandBarStateAutomation.xml. This keeps it separate from the 
menu and toolbar state when MapInfo Professional is run as a desktop application on the same machine 
by the same user. This file is written to the same user folder as MICommandBarState.xml. 

T29442 The cartographic scale does not match the layout or printout scale.

Resolution: Issue is resolved. The scale bar was using the cartographic scale value from the mapper. In 
some cases, the cartographic scale is different when the map is in a layout or printout. MapInfo 
Professional now displays the correct cartographic scale.

T29514 Web Mapping Service (WMS) 1.3 Servers expect coordinates for EPSG codes to be in Latitude 
Longitude order rather than Longitude Latitude. For some projected coordinate systems, MapInfo 
Professional puts images in the wrong place and skews them.

Resolution: Issue is resolved. MapInfo Professional was not correctly interpreting coordinate system 
bounds for many EPSG coordinate systems for WMS 1.3 servers.  This was causing images generated 
from these servers to appear distorted and in the wrong location in a Map window.

T29557 MapInfo Professional displays the error "Coordinate System of ‘created table name' differs from ‘table 
name’”. 

The Seamless Table Manager tool prompts to continue or skip a source table if the bounds of the source 
table are not same as the bounds of first table. This occurs even when the coordinate system of two 
tables are same.

Resolution: MapInfo Professional no longer compares the difference in bounds for raster tables. The 
behavior remains unchanged for vector tables; a prompt displays to continue or skip a source table.

T29619 Zooming a Layout window causes the window to redraw incorrectly when Enhanced Rendering is set to 
off and the Layout window has a Frame that has the Fill Frame with Contents set to off. You will see 
remnants of the previous zoom level left behind.

Resolution: Issue is resolved.

T29676 Combine object using column takes a long time when enhanced rendering is on.

Resolution: Issue is resolved. 

UC11030
UC11038

MapInfo Professional ignores the ComplexType extension when importing Geographic Markup 
Language (GML).

Resolution: Issue is resolved. MapInfo Professional now supports common schema, so that a schema 
can derive from a common one and inherits its attributes and fields.

Issue Description and Resolution
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SQL Server, PostGIS, and Oracle

MapInfo PDF Printer

Issue Description and Resolution

C15810 A Boolean field from PostGIS downloads as a character (1) field in MapInfo Professional.

Resolution: The ODBC Data Source for PostGIS has a data type option called Bools as Char that is 
checked by default. To download a Boolean field as a Logical field in MapInfo Professional, uncheck 
Bools as Char in the PostGIS ODBC dialog called Advanced Options (PostGIS) 1/2. To do this:

1. From the Start menu, select Control Panel > Administrative Tools > Data Sources (ODBC). 
2. In the ODBC Data Source Administrator dialog, under the System DSN tab select your PostGIS data 

source and click Configure. 
3. In the PostgresSQL ANSI ODBC Driver (psqlODBC) Setup dialog, in the Options pane click 

Datasource.
4. In the Advanced Options (PostGIS) 1/2 dialog, uncheck the Bools as Char checkbox and click OK.

T28971 Saving or creating a new table to PostGIS on a Linux operating system generates an unknown EPSG 
code error message.

Resolution: Issue is resolved. MapInfo Professional uses some EPSG codes (such as 41001) that 
PostGIS on a Linux platform does not support. To fix this issue, a code (-1) that is unknown to PostGIS 
replaces the unsupported EPSG codes.

T25293 Opening a SQL Server table containing a column with type NCHAR causes an error message, 
“Unsupported data type for column...”

Resolution: Issue is resolved.

T29052 An Oracle Error message displays when editing a geometry that has a mi_Style column name in 
lowercase on an Oracle Spatial server.

Resolution: Issue is resolved.

T29552 Refreshing a PostGIS table causes MapInfo Professional to open multiple connections to the database. 

Resolution: Issue is resolved.

Issue Description and Resolution

T29060 Printing to the MapInfo PDF printer 10 takes a long time for some data when printing with the registry 
setting PolygonMode = 1.

Resolution: Issue is resolved. The polygon drawing behavior defaults to PolygonMode = 0 unless the 
PolygonMode registry setting is set to 1.

T29147 Unable to open a Layered PDF that has a theme based on an expression. This is a result of having "(" 
and ")" in the display names of thematic layers, which has a special meaning for the PDF driver.

Resolution: Issue is resolved.
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Layer Control

Issue Description and Resolution

C15809 MapInfo Professional closes unexpectedly when the Layer Control window is open while trying to open a 
Relational Database (RDB) cache layer on top of a theme layer.

Resolution: Issue is resolved. 

IN14102 The Layer Control window displays if you change the Windows theme while MapInfo Professional is 
minimized. 

Resolution: Issue is resolved.

IN14175 An error message sometimes appears after copying a raster image layer to another map by dragging 
and dropping the layer within the Layer Control. 

Resolution: Issue is resolved.

IN14226 Opening a map for the second time disables the Add Layer button.

Resolution: Issue is resolved.

IN14528 The name of the selected layer in the Layer Control becomes unreadable, because it displays in white 
text on a very light gray background when a dialog box takes the focus away from the layer list. 

Resolution: Issue is resolved.

T28610 Performing a shift-click in the Layer Control list sometimes sets the Selectable or Autolabel check boxes 
instead of selecting layers.

Resolution: Issue is resolved.

T28688 Selecting all non-cosmetic layers and then clicking Remove, removes all layers and closes the map.

Resolution: The Remove button disables when removing the selection of layers would cause the map 
window to close. To enable the Remove button, de-select layers.

T28717 Standard dialog keyboard handling is not working in the modal Layer Control dialog: pressing the Enter 
and Escape keys does not dismiss the dialog, and the TAB key does not navigate to the next control.

Resolution: Issue is resolved.

T28812 When adding a new group layer in the Layer Control, the group name is not editable until it is selected.

Resolution: Issue is resolved. When adding a new group layer, the group name is now automatically 
highlighted, so that you can start typing a new name. 

T28982, 
T29008

After expanding a layer list, the Layer Control sometimes resets the layer list back to its original collapsed 
state. 

Resolution: Issue is resolved.

T29118 The Layer Control lists all maps including re-parented maps (maps that display inside of another 
application or dialog box, such as the North Arrow tool). Users interacting with the map entry in the Layer 
Control window may see an error message.

Resolution: Issue is resolved. Re-parented maps are a special case and should not be in the Layer 
Control list.

T29123 In the Layer Control, the group folder does not automatically expand when adding a sub-group. As a 
result, you have to manually expand the group folder to see the new sub-group.

Resolution: Issue is resolved.
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EasyLoader
Easyloader does not have the New Zealand Transverse Mercator (NZTM) coordinate system in its lookup list, so when 
using EasyLoader to upload a table into Oracle 10g or 11g, the SRID defaults to Null.

Resolution: The following SRID support was added for Oracle.

T29136 When copying a Grid layer to another map by dragging and dropping it, the Grid does not preserve all of 
its settings.

Resolution: Issue is resolved.

T29213, 
T29415

Removing a Group Layer, such as a nested Group Layer, causes the Layer Control to display incorrect 
results in the layer list.

Resolution: Issue is resolved.

T29246 When a map contains multiple dot-density themes, you cannot rearrange the themes in the Layer Control 
list.

Resolution: Issue is resolved.

T29322 Opening the Layer Control in auto-hide mode (unpinned) may cause the Layer Control to freeze in the 
hidden state, so that you can not make it reappear. 

Resolution: Issue is resolved.

T29334 When copying a layer to another map by dragging and dropping it, the layer's Default Theme is 
sometimes added to the original map instead of to the target map. 

Resolution: Issue is resolved.

T29454 When a layer name ends in a single underscore, such as "WORLD_," then displaying the layer's tool tip, 
by hovering over the layer name in Layer Control, could cause MapInfo Professional to close 
unexpectedly.

Resolution: Issue is resolved.

T29491 Renaming a map by right-clicking on its name and then closing MapInfo Professional while the map 
name is in edit mode, displays an error message.

Resolution: Issue is resolved.

T29546 If the Layer Control is set to show only one active map window, then displaying the Layer Properties 
dialog also unselects the selected layer.

Resolution: Issue is resolved. The selected layer now remains selected.

Issue Description and Resolution

SRID CS_NAME

2105 NZGD2000 / Mount Eden Circuit 2000

2106 NZGD2000 / Bay of Plenty Circuit 2000

2107 NZGD2000 / Poverty Bay Circuit 2000

2108 NZGD2000 / Hawkes Bay Circuit 2000

2109 NZGD2000 / Taranaki Circuit 2000

2110 NZGD2000 / Tuhirangi Circuit 2000
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2111 NZGD2000 / Wanganui Circuit 2000

2112 NZGD2000 / Wairarapa Circuit 2000

2113 NZGD2000 / Wellington Circuit 2000

2114 NZGD2000 / Collingwood Circuit 2000

2115 NZGD2000 / Nelson Circuit 2000

2116 NZGD2000 / Karamea Circuit 2000

2117 NZGD2000 / Buller Circuit 2000

2118 NZGD2000 / Grey Circuit 2000

2119 NZGD2000 / Amuri Circuit 2000

2120 NZGD2000 / Marlborough Circuit 2000

2121 NZGD2000 / Hokitika Circuit 2000

2122 NZGD2000 / Okarito Circuit 2000

2123 NZGD2000 / Jacksons Bay Circuit 2000

2124 NZGD2000 / Mount Pleasant Circuit 2000

2125 NZGD2000 / Gawler Circuit 2000

2126 NZGD2000 / Timaru Circuit 2000

2127 NZGD2000 / Lindis Peak Circuit 2000

2128 NZGD2000 / Mount Nicholas Circuit 2000

2129 NZGD2000 / Mount York Circuit 2000

2130 NZGD2000 / Observation Point Circuit 2

2131 NZGD2000 / North Taieri Circuit 2000

2132 NZGD2000 / Bluff Circuit 2000

2193 NZGD2000 / New Zealand Transverse Mercator

SRID CS_NAME
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MapBasic

Issue Description and Resolution

S10039 The Table Manager stops unexpectedly when exporting out to a .met/.txt file if the record before or just 
after '\isReadOnly' contains only one level of hierarchy. MapInfo Professional is then left in a frozen state.

Resolution: Issue is resolved.

S10054 MapBasic no longer displays lowercase Menu shortcuts. In version 9.5 and earlier, you could create a 
menu item in MapBasic using a lower case letter for the item's accelerator key and the menu would 
display the lower case letter. (See Create Menu for reference.)  

Resolution: MapBasic no longer supports displaying the accelerator as a lower case letter. You can still 
define a menu item with a lower case letter for an accelerator, but it displays in the menu in upper case 
(you do not need the Shift key to invoke it). As an example, the following snippet of MapBasic creates a 
menu with an item called Point Select:

Create Menu "Sample" As
"Point Select" + Chr$(9) + "p /Wp" ID 901 Calling M_TOOLS_SELECTOR

The menu displays the accelerator as uppercase

Point Select         P

Clicking the 'p' key calls the handler for  M_TOOLS_SELECTOR.

T28079 MapInfo Professional closes unexpectedly when adding a column statement to update the geographical 
column in one table with the values from the geographical column from another table. The following 
example illustrates this issue:

Add Column "TabWithoutObjects" (OBJ) From TabWithObjects Set To OBJ Where 
COL1 = COL1

Resolution: Issue is resolved. MapInfo Professional does not support updating the OBJ column or the 
RowID column using an "Add Column …." statement. Now, updating these two columns using an "Add 
Column ….." statement generates an error message and MapInfo Professional does not close 
unexpectedly.

T29036 Failure may occur in MapInfo Professional after repeatedly loading and unloading a custom menu for a 
MapBasic program.

Resolution: Issue is resolved.

T29214 Certain complex MapBasic REMOVE MAP statements could cause MapInfo Professional to close 
unexpectedly when removing nested groups. 

Resolution: Issue is resolved.
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T29224 Prior to MapInfo Professional 10.0 you could create a disabled submenu by pre-pending the menu item 
name with the "(" character. For example: 

Create Menu "Sample Menu" As 
  "&First item" 
   HelpMsg "This is the first item in this menu." 
Create Menu "Menu Test" as 
    "Item A" 
    "(-", 
    "(Sample Submenu Item" As "Sample Menu", 
    "Item B" 
    ... 
Alter Menu Bar add "Menu Test" 

In this example, Sample Submenu Item is added to the Menu Test menu where Sample Menu is the 
name of an existing menu to include as a hierarchical submenu. The "(" character at the beginning of 
Sample Submenu Item should disable the item, so that it displays in gray in the Menu Test menu. 
However, in version 10.0 the item is enabled.

Resolution: Issue is resolved.

T29263 A resource DLL can contain one or more resources, such as bitmaps for icons on toolbar buttons. 
MapInfo Professional 10.0 shows an issue when two different DLLs use resources with the same ID. If 
you create two different buttons, you should see two different icons. Instead, in version 10.0, you see two 
buttons that show the same button image.

Resolution: Issue is resolved. If there are two different resource DLLs that have the same resource ID 
(each with a different image):

Resource1.dll, ID=100
Resource2.dll, ID=100

Then you can create a button pad with the two different images for the two buttons:

Create ButtonPad "IcoTest" As
        PushButton Calling TestDLLCall
            Icon 100 File "Resource1.dll"
            HelpMsg "Resource1.dll.\nTest"
        PushButton Calling TestDLLCall
            Icon 100 File "Resource2.dll"
            HelpMsg "Resource2.dll.\nTest"

T29462 Older MapBasic utilities (MBX files) that call routines in older Dynamic Link Libraries (DLL files) may 
cause MapInfo Professional to close unexpectedly. Running a MapBasic utility (MBX file) and then 
displaying the Layer Control window triggers this.

Resolution: Issue is resolved.

T29665 Calling WindowID( ) in MapInfo Professional 10.0, when there is a scale bar adornment in a map window, 
returns the WindowID of the adornment.

Resolution: Issue is resolved. To obtain an adornments window identifier, use NumAllWindows( ) to find 
the adornment's negative index and then pass that to WindowID( ).

Issue Description and Resolution
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Working with Layers in MapBasic

Issue Description and Resolution

C15790 In the dialog box version of the Layer Control, which only applies to older MapBasic programs, the act of 
adding a new layer interferes with group layers—adding a new layer, pulls other layers out of their 
respective groups (folders).

Resolution: Issue is resolved.

IN14192 If the map contains Group Layers, then the dialog box version of Layer Control, used only by MapBasic 
programs, does not allow removal or reordering of layers.

Resolution: Issue is resolved.

T27511 Using a LayerInfo command inside a WinCloseHandler could cause MapInfo Professional to close 
unexpectedly.

Resolution: MapInfo Professional no longer closes unexpectedly. Instead, it now supplies an error 
message, “Unknown error occurred”. This issue is scheduled for resolution in the next release.

T28688 The dialog box version of Layer Control, used only by MapBasic programs, lets you remove all layers, 
which causes the map window to close automatically. 

Resolution: Issue is resolved.

T29138 LayerListInfo with ID=0 should return information about the Cosmetic Layer, and GroupLayerInfo with 
ID=0 should not return an empty string.

Resolution: Issue is resolved:

• LayerListInfo() works for map layers with id = 0 to MAPPER_INFO_ALL_LAYERS. Also, 
LayerListInfo() with id=0 now returns information about the Cosmetic layer.

• GroupLayerInfo() with ID=0 now returns the name of the MAP Window, and returns the name of the 
Cosmetic Layer as "cosmetic1", "cosmetic2".
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